Bug 33092 - [regression] 2.6.39-rc1 - Beagleboard usbnet broken
[regression] 2.6.39-rc1 - Beagleboard usbnet broken
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 32012
  Show dependency treegraph
 
Reported: 2011-04-11 19:33 UTC by Maciej Rutecki
Modified: 2011-05-14 21:59 UTC (History)
7 users (show)

See Also:
Kernel Version: 2.6.39-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-04-11 19:33:01 UTC
Subject    : [regression] 2.6.39-rc1 - Beagleboard usbnet broken
Submitter  : Mark Jackson <mpfj-list@mimc.co.uk>
Date       : 2011-04-04 9:22
Message-ID : 4D998DC9.3040109@mimc.co.uk
References : http://marc.info/?l=linux-kernel&m=130191386508831&w=2

This entry is being used for tracking a regression from 2.6.38. Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 087809fce28f50098d9c3ef1a6865c722f23afd2
Author: Jamie Iles <jamie@jamieiles.com>
Date:   Fri Jan 21 14:11:52 2011 +0000

    dmaengine/dw_dmac: don't scan descriptors if no xfers in progress

    Signed-off-by: Jamie Iles <jamie.iles@picochip.com>
    Signed-off-by: Dan Williams <dan.j.williams@intel.com>

First-Bad-Commit : 087809fce28f50098d9c3ef1a6865c722f23afd2
Comment 1 Alan Ott 2011-04-22 01:08:17 UTC
A comment I found last night (I can't find it now) linked this bug to this thread about the regulator driver being broken:
   http://thread.gmane.org/gmane.linux.ports.arm.omap/56105

In my testing (-rc4+), it looks like the regulator problem is indeed preventing the USB Ethernet port and the hub that it's attached to from being powered up.

Keshava Munegowda indicated that he would be working on this during the week of April 17, 2011.
Comment 2 Rafael J. Wysocki 2011-05-06 17:33:12 UTC
On Friday, May 06, 2011, Mark Jackson wrote:
> On 30/04/11 20:46, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a summary report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.38.  Please verify if it still should be listed and let the tracking team
> > know (either way).
> 
> I have just tried the latest linus git and it is still broken.
> 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=33092
> > Subject		: [regression] 2.6.39-rc1 - Beagleboard usbnet broken
> > Submitter	: Mark Jackson <mpfj-list@mimc.co.uk>
> > Date		: 2011-04-04 9:22 (27 days old)
Comment 3 Florian Mickler 2011-05-09 09:56:22 UTC
Ok, I'm not really getting the whole discussion, but it seems the issue is fixed.. at least somewhere. 

There seem to be 2 fixes for this issue:
Patch: https://lkml.org/lkml/2011/4/14/45

And the patch by Munegowda as mentioned here: 
http://www.spinics.net/lists/linux-usb/msg45918.html


Mark, can you confirm that the patch https://lkml.org/lkml/2011/4/14/45 fixes the issue for you?
Comment 4 Mark Jackson 2011-05-10 08:17:40 UTC
I can confirm that the patch at https://lkml.org/lkml/2011/4/14/45 *does* fix
the issue.

Cheers
Comment 5 Rafael J. Wysocki 2011-05-14 21:59:37 UTC
Fixed by commit 557f447f21621de9c5447c8702c33b53279822ce .

Note You need to log in before you can comment on or make changes to this bug.