Bug 3291 - store_edid hangs boot
Summary: store_edid hangs boot
Status: REJECTED DUPLICATE of bug 1458
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386 (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Zwane Mwaikambo
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-08-27 17:56 UTC by Michael Douglass
Modified: 2004-11-30 23:37 UTC (History)
0 users

See Also:
Kernel Version: 2.6.0-2.6.8.1
Tree: Mainline
Regression: ---


Attachments

Description Michael Douglass 2004-08-27 17:56:36 UTC
Distribution:
 Fedora Core II as well as the vanilla kernal from kernel.org

Hardware Environment:
 P3 500
 Diamond Viper 770D Ultra NVIDIA

Software Environment:
 This occurs with kernel versions starting with 2.6.0 (did not check 2.5 to 
see where it started in there but that would be easy to check since I've found 
WHERE the problem is).

Problem Description:
 When I boot a 2.6.x kernel compiled with CONFIG_VIDEO_SELECT=y my system 
hangs after grub prints out the boot lines and their respective responses.

 I have debugged it down to the store_edid function.  If I #if 0 out that 
section, I get no hang.  The simplest fix for me is to set 
CONFIG_VIDEO_SELECT=n and recompile the kernel -- only it's quite annoying to 
have to do that every time a kernel is released.

For more complete information, please see my bugzilla ticket on 
redhat.bugzilla.com:  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?
id=130737
Comment 1 Michael Douglass 2004-09-01 12:09:19 UTC
Changing severity to normal, it's not stopping me from using my system any
longer -- and anyone else with the same problem can use my work around.
Comment 2 Zwane Mwaikambo 2004-11-30 23:37:56 UTC

*** This bug has been marked as a duplicate of 1458 ***

Note You need to log in before you can comment on or make changes to this bug.