Bug 32652 - System locks up after resuming from s2disk (bisected)
System locks up after resuming from s2disk (bisected)
Status: CLOSED DUPLICATE of bug 32222
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 high
Assigned To: Yinghai Lu
:
Depends on:
Blocks: 7216 32012
  Show dependency treegraph
 
Reported: 2011-04-04 18:20 UTC by cantabile
Modified: 2011-04-16 17:07 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.38.2
Tree: Mainline
Regression: Yes


Attachments
output of 'git bisect log' (1.10 KB, text/plain)
2011-04-04 18:23 UTC, cantabile
Details
Photo of panic backtrace (190.62 KB, image/jpeg)
2011-04-05 22:52 UTC, Sami Liedes
Details

Description cantabile 2011-04-04 18:20:53 UTC
Hi,

Since the upgrade from 2.6.38.1 to 2.6.38.2, my laptop always locks up after resuming from hibernation.

I use pm-hibernate, usually with SLEEP_MODULE=uswsusp. Adding a 30 second delay after the resume ("resume pause = 30" in /etc/suspend.conf) I can see that the hibernation image is read successfully and the system locks up right before uswsusp should print "returned to userspace" and, well, return to whatever was running before hibernating. The screen goes blank, powered up, but blank. Sysrq doesn't work, I had to use the power button.

Calling s2disk directly leads to the same result.

Using pm-hibernate with SLEEP_MODULE=kernel leads to a slighty different result: in addition to the above, the caps lock led lights up (and remains lit) when the system locks up.

I cloned this: git://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-2.6.38.y.git and bisected using 'v2.6.38.1' for "good" and 'v2.6.38.2' for "bad". This is what I got:

ff518ea26654e05d325d996f6e3a7f5f569cc2d5 is the first bad commit
commit ff518ea26654e05d325d996f6e3a7f5f569cc2d5
Author: Yinghai Lu <yinghai@kernel.org>
Date:   Fri Feb 18 11:30:30 2011 +0000

    x86: Cleanup highmap after brk is concluded
    
    commit e5f15b45ddf3afa2bbbb10c7ea34fb32b6de0a0e upstream.
    
    Now cleanup_highmap actually is in two steps: one is early in head64.c
    and only clears above _end; a second one is in init_memory_mapping() and
    tries to clean from _brk_end to _end.
    It should check if those boundaries are PMD_SIZE aligned but currently
    does not.
    Also init_memory_mapping() is called several times for numa or memory
    hotplug, so we really should not handle initial kernel mappings there.
    
    This patch moves cleanup_highmap() down after _brk_end is settled so
    we can do everything in one step.
    Also we honor max_pfn_mapped in the implementation of cleanup_highmap.
    
    Signed-off-by: Yinghai Lu <yinghai@kernel.org>
    Signed-off-by: Stefano Stabellini <stefano.stabellini@eu.citrix.com>
    LKML-Reference: <alpine.DEB.2.00.1103171739050.3382@kaball-desktop>
    Signed-off-by: H. Peter Anvin <hpa@zytor.com>
    Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>

:040000 040000 b5ed0c2971ba1162c7cd289dd351d1700eb52fbc 8f830fdb43fa30ddebb485e6f6455d669300874b M      arch

The hardware:
00:00.0 Host bridge: Intel Corporation Mobile GME965/GLE960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GME965/GLE960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GME965/GLE960 Integrated Graphics Controller (rev 0c)
00:19.0 Ethernet controller: Intel Corporation 82562GT 10/100 Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
10:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)

It's an HP Compaq 6720s laptop.
Cpu: intel core2 duo t5470 at 1.6 GHz
Ram: 2 GB

Operating system:
Arch linux x86_64

That's all the info I can think of, at the moment.
Comment 1 cantabile 2011-04-04 18:23:26 UTC
Created attachment 53482 [details]
output of 'git bisect log'
Comment 2 Sami Liedes 2011-04-05 22:51:25 UTC
I have this same problem on Acer Aspire 5810TZ.

The *stable update* 2.6.37.6 also broke this. 2.6.37.5 worked fine.

I can confirm that on 2.6.38.2 with ff518ea26654e05d325d996f6e3a7f5f569cc2d5 reverted hibernate/resume works fine.

With kernel parameter no_console_suspend, I can see a kernel panic. On 80x50 screen it isn't entirely visible, but pretty much of it is (see attached photo).

Output from lspci -v:


00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
	Subsystem: Acer Incorporated [ALI] Device 022b
	Flags: bus master, fast devsel, latency 0
	Capabilities: [e0] Vendor Specific Information: Len=0a <?>
	Kernel driver in use: agpgart-intel

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07) (prog-if 00 [VGA controller])
	Subsystem: Acer Incorporated [ALI] Device 022b
	Flags: bus master, fast devsel, latency 0, IRQ 44
	Memory at d0000000 (64-bit, non-prefetchable) [size=4M]
	Memory at c0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at 4110 [size=8]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
	Capabilities: [d0] Power Management version 3
	Kernel driver in use: i915

00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
	Subsystem: Acer Incorporated [ALI] Device 022b
	Flags: fast devsel
	Memory at d4500000 (64-bit, non-prefetchable) [disabled] [size=1M]
	Capabilities: [d0] Power Management version 3

00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03) (prog-if 00 [UHCI])
	Subsystem: Acer Incorporated [ALI] Device 022b
	Flags: bus master, medium devsel, latency 0, IRQ 16
	I/O ports at 40e0 [size=32]
	Capabilities: [50] PCI Advanced Features
	Kernel driver in use: uhci_hcd

00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03) (prog-if 00 [UHCI])
	Subsystem: Acer Incorporated [ALI] Device 022b
	Flags: bus master, medium devsel, latency 0, IRQ 21
	I/O ports at 40c0 [size=32]
	Capabilities: [50] PCI Advanced Features
	Kernel driver in use: uhci_hcd

00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03) (prog-if 20 [EHCI])
	Subsystem: Acer Incorporated [ALI] Device 022b
	Flags: bus master, medium devsel, latency 0, IRQ 19
	Memory at d4405c00 (32-bit, non-prefetchable) [size=1K]
	Capabilities: [50] Power Management version 2
	Capabilities: [58] Debug port: BAR=1 offset=00a0
	Capabilities: [98] PCI Advanced Features
	Kernel driver in use: ehci_hcd

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
	Subsystem: Acer Incorporated [ALI] Device 022b
	Flags: bus master, fast devsel, latency 0, IRQ 11
	Memory at d4400000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: [50] Power Management version 2
	Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
	Capabilities: [100] Virtual Channel
	Capabilities: [130] Root Complex Link

00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03) (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
	I/O behind bridge: 00003000-00003fff
	Memory behind bridge: d3400000-d43fffff
	Prefetchable memory behind bridge: 00000000d0400000-00000000d13fffff
	Capabilities: [40] Express Root Port (Slot+), MSI 00
	Capabilities: [80] MSI: Enable+ Count=1/1 Maskable- 64bit-
	Capabilities: [90] Subsystem: Acer Incorporated [ALI] Device 022b
	Capabilities: [a0] Power Management version 2
	Capabilities: [100] Virtual Channel
	Capabilities: [180] Root Complex Link
	Kernel driver in use: pcieport

00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03) (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0
	Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
	I/O behind bridge: 00002000-00002fff
	Memory behind bridge: d2400000-d33fffff
	Prefetchable memory behind bridge: 00000000d1400000-00000000d23fffff
	Capabilities: [40] Express Root Port (Slot+), MSI 00
	Capabilities: [80] MSI: Enable+ Count=1/1 Maskable- 64bit-
	Capabilities: [90] Subsystem: Acer Incorporated [ALI] Device 022b
	Capabilities: [a0] Power Management version 2
	Capabilities: [100] Virtual Channel
	Capabilities: [180] Root Complex Link
	Kernel driver in use: pcieport

00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03) (prog-if 00 [UHCI])
	Subsystem: Acer Incorporated [ALI] Device 022b
	Flags: bus master, medium devsel, latency 0, IRQ 23
	I/O ports at 40a0 [size=32]
	Capabilities: [50] PCI Advanced Features
	Kernel driver in use: uhci_hcd

00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03) (prog-if 00 [UHCI])
	Subsystem: Acer Incorporated [ALI] Device 022b
	Flags: bus master, medium devsel, latency 0, IRQ 19
	I/O ports at 4080 [size=32]
	Capabilities: [50] PCI Advanced Features
	Kernel driver in use: uhci_hcd

00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03) (prog-if 00 [UHCI])
	Subsystem: Acer Incorporated [ALI] Device 022b
	Flags: bus master, medium devsel, latency 0, IRQ 16
	I/O ports at 4060 [size=32]
	Capabilities: [50] PCI Advanced Features
	Kernel driver in use: uhci_hcd

00:1d.3 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03) (prog-if 00 [UHCI])
	Subsystem: Acer Incorporated [ALI] Device 022b
	Flags: bus master, medium devsel, latency 0, IRQ 18
	I/O ports at 4040 [size=32]
	Capabilities: [50] PCI Advanced Features
	Kernel driver in use: uhci_hcd

00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03) (prog-if 20 [EHCI])
	Subsystem: Acer Incorporated [ALI] Device 022b
	Flags: bus master, medium devsel, latency 0, IRQ 23
	Memory at d4405800 (32-bit, non-prefetchable) [size=1K]
	Capabilities: [50] Power Management version 2
	Capabilities: [58] Debug port: BAR=1 offset=00a0
	Capabilities: [98] PCI Advanced Features
	Kernel driver in use: ehci_hcd

00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93) (prog-if 01 [Subtractive decode])
	Flags: bus master, fast devsel, latency 0
	Bus: primary=00, secondary=03, subordinate=03, sec-latency=32
	Capabilities: [50] Subsystem: Acer Incorporated [ALI] Device 022b

00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
	Subsystem: Acer Incorporated [ALI] Device 022b
	Flags: bus master, medium devsel, latency 0
	Capabilities: [e0] Vendor Specific Information: Len=0c <?>

00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03) (prog-if 01 [AHCI 1.0])
	Subsystem: Acer Incorporated [ALI] Device 022b
	Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 42
	I/O ports at 4108 [size=8]
	I/O ports at 411c [size=4]
	I/O ports at 4100 [size=8]
	I/O ports at 4118 [size=4]
	I/O ports at 4020 [size=32]
	Memory at d4405000 (32-bit, non-prefetchable) [size=2K]
	Capabilities: [80] MSI: Enable+ Count=1/16 Maskable- 64bit-
	Capabilities: [70] Power Management version 3
	Capabilities: [a8] SATA HBA v1.0
	Capabilities: [b0] PCI Advanced Features
	Kernel driver in use: ahci

00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
	Subsystem: Acer Incorporated [ALI] Device 022b
	Flags: medium devsel, IRQ 11
	Memory at d4406000 (64-bit, non-prefetchable) [size=256]
	I/O ports at 4000 [size=32]

00:1f.6 Signal processing controller: Intel Corporation 82801I (ICH9 Family) Thermal Subsystem (rev 03)
	Subsystem: Acer Incorporated [ALI] Device 022b
	Flags: fast devsel, IRQ 11
	Memory at d4404000 (64-bit, non-prefetchable) [size=4K]
	Capabilities: [50] Power Management version 3

01:00.0 Ethernet controller: Atheros Communications AR8131 Gigabit Ethernet (rev c0)
	Subsystem: Acer Incorporated [ALI] Device 022b
	Flags: bus master, fast devsel, latency 0, IRQ 43
	Memory at d3400000 (64-bit, non-prefetchable) [size=256K]
	I/O ports at 3000 [size=128]
	Capabilities: [40] Power Management version 3
	Capabilities: [48] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [58] Express Endpoint, MSI 00
	Capabilities: [6c] Vital Product Data
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [180] Device Serial Number ff-ac-42-e7-00-1f-16-ff
	Kernel driver in use: atl1c

02:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000
	Subsystem: Intel Corporation Centrino Wireless-N 1000 BGN
	Flags: bus master, fast devsel, latency 0, IRQ 11
	Memory at d2400000 (64-bit, non-prefetchable) [size=8K]
	Capabilities: [c8] Power Management version 3
	Capabilities: [d0] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [e0] Express Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Device Serial Number 00-1e-64-ff-ff-05-23-0a
Comment 3 Sami Liedes 2011-04-05 22:52:18 UTC
Created attachment 53612 [details]
Photo of panic backtrace
Comment 4 Egor Y. Egorov 2011-04-09 08:18:51 UTC
I have same issue on 2.6.38.2: PC locks up after resuming from hibernation.
With 2.6.38 all Ok.
Comment 5 cantabile 2011-04-16 08:30:29 UTC
Turns out this bug was already reported: https://bugzilla.kernel.org/show_bug.cgi?id=32222
The patch mentioned there ( https://patchwork.kernel.org/patch/679502/ ) solves the problem for me.
Comment 6 Rafael J. Wysocki 2011-04-16 17:07:05 UTC

*** This bug has been marked as a duplicate of bug 32222 ***

Note You need to log in before you can comment on or make changes to this bug.