Bug 32522 - drm:i915_hangcheck_ring_idle after suspend/resume cycle
drm:i915_hangcheck_ring_idle after suspend/resume cycle
Status: CLOSED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 7216 27352
  Show dependency treegraph
 
Reported: 2011-04-02 18:40 UTC by fhimpe
Modified: 2011-05-17 07:47 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.38
Tree: Mainline
Regression: Yes


Attachments
dmesg (123.23 KB, text/plain)
2011-04-02 18:43 UTC, fhimpe
Details
Xorg.0.log (35.79 KB, text/x-log)
2011-04-02 18:44 UTC, fhimpe
Details

Description fhimpe 2011-04-02 18:40:28 UTC
After some suspend/resume cycles on my Samsung N210 netbook with Atom N450 CPU, graphics become very slow/unusable, and my dmesg is full om errors like this:

[43373.908075] [drm:i915_hangcheck_ring_idle] *ERROR* Hangcheck timer elapsed... render ring idle [waiting on 222265, at 222266], missed IRQ?
[43375.476057] [drm:i915_hangcheck_ring_idle] *ERROR* Hangcheck timer elapsed... render ring idle [waiting on 222400, at 222411], missed IRQ?
[43377.232050] [drm:i915_hangcheck_ring_idle] *ERROR* Hangcheck timer elapsed... render ring idle [waiting on 222624, at 222624], missed IRQ?
[43378.760071] [drm:i915_hangcheck_ring_idle] *ERROR* Hangcheck timer elapsed... render ring idle [waiting on 222655, at 222657], missed IRQ?
[43380.416061] [drm:i915_hangcheck_ring_idle] *ERROR* Hangcheck timer elapsed... render ring idle [waiting on 222835, at 222837], missed IRQ?

00:02.1 Display controller [0380]: Intel Corporation N10 Family Integrated Graphics Controller [8086:a012]

I'm running Debian testing/unstable with:
Linux netbook 2.6.38-2-amd64 #1 SMP Tue Mar 29 16:45:36 UTC 2011 x86_64 GNU/Linux
(2.6.38.2 based kernel, also happened with 2.6.38.0 kernel but dit not happen with 2.6.37).

ii  libdrm-intel1                                2.4.23-3                          Userspace interface to intel-specific kernel DRM services -- runtime
ii  libdrm-nouveau1a                             2.4.23-3                          Userspace interface to nouveau-specific kernel DRM services -- runtime
ii  libdrm-radeon1                               2.4.23-0.0                        Userspace interface to radeon-specific kernel DRM services -- runtime
ii  libdrm2                                      2.4.23-0.0                        Userspace interface to kernel DRM services -- runtime
ii  libegl1-mesa                                 7.10-4                            A free implementation of the EGL API -- runtime
ii  libgl1-mesa-dri                              7.10-4                            A free implementation of the OpenGL API -- DRI modules
ii  libgl1-mesa-glx                              7.10-4                            A free implementation of the OpenGL API -- GLX runtime
ii  libglu1-mesa                                 7.10-4                            The OpenGL utility library (GLU)
ii  mesa-utils                                   8.0.1-2                           Miscellaneous Mesa GL utilities
ii  xserver-xorg                                 1:7.5+8                           the X.Org X server
ii  xserver-xorg-core                            2:1.9.5-1                         Xorg X server - core server
ii  xserver-xorg-input-all                       1:7.5+8                           the X.Org X server -- input driver metapackage
ii  xserver-xorg-input-evdev                     1:2.6.0-2                         X.Org X server -- evdev input driver
ii  xserver-xorg-input-synaptics                 1.4.0-1                           Synaptics TouchPad driver for X.Org server
ii  xserver-xorg-input-wacom                     0.10.10+20110203-1                X.Org X server -- Wacom input driver
ii  xserver-xorg-video-all                       1:7.6+5                           the X.Org X server -- output driver metapackage
ii  xserver-xorg-video-apm                       1:1.2.3-2                         X.Org X server -- APM display driver
ii  xserver-xorg-video-ark                       1:0.7.3-2                         X.Org X server -- ark display driver
ii  xserver-xorg-video-ati                       1:6.14.0-1                        X.Org X server -- AMD/ATI display driver wrapper
ii  xserver-xorg-video-chips                     1:1.2.4-1                         X.Org X server -- Chips display driver
ii  xserver-xorg-video-cirrus                    1:1.3.2-4                         X.Org X server -- Cirrus display driver
ii  xserver-xorg-video-fbdev                     1:0.4.2-4                         X.Org X server -- fbdev display driver
ii  xserver-xorg-video-i128                      1:1.3.4-2                         X.Org X server -- i128 display driver
ii  xserver-xorg-video-intel                     2:2.14.0-4                        X.Org X server -- Intel i8xx, i9xx display driver
ii  xserver-xorg-video-mach64                    6.8.2-5                           X.Org X server -- ATI Mach64 display driver
ii  xserver-xorg-video-mga                       1:1.4.13.dfsg-3                   X.Org X server -- MGA display driver
ii  xserver-xorg-video-neomagic                  1:1.2.5-2                         X.Org X server -- Neomagic display driver
ii  xserver-xorg-video-nouveau                   1:0.0.16+git20101210+8bb8231-2    X.Org X server -- Nouveau display driver (experimental)
ii  xserver-xorg-video-openchrome                1:0.2.904+svn918-1                X.Org X server -- VIA display driver
ii  xserver-xorg-video-r128                      6.8.1-5                           X.Org X server -- ATI r128 display driver
ii  xserver-xorg-video-radeon                    1:6.14.0-1                        X.Org X server -- AMD/ATI Radeon display driver
ii  xserver-xorg-video-rendition                 1:4.2.4-2                         X.Org X server -- Rendition display driver
ii  xserver-xorg-video-s3                        1:0.6.3-4                         X.Org X server -- legacy S3 display driver
ii  xserver-xorg-video-s3virge                   1:1.10.4-4                        X.Org X server -- S3 ViRGE display driver
ii  xserver-xorg-video-savage                    1:2.3.2-3                         X.Org X server -- Savage display driver
ii  xserver-xorg-video-siliconmotion             1:1.7.5-1                         X.Org X server -- SiliconMotion display driver
ii  xserver-xorg-video-sis                       1:0.10.3-3                        X.Org X server -- SiS display driver
ii  xserver-xorg-video-sisusb                    1:0.9.4-2                         X.Org X server -- SiS USB display driver
ii  xserver-xorg-video-tdfx                      1:1.4.3-4                         X.Org X server -- tdfx display driver
ii  xserver-xorg-video-trident                   1:1.3.4-2                         X.Org X server -- Trident display driver
ii  xserver-xorg-video-tseng                     1:1.2.4-2                         X.Org X server -- Tseng display driver
ii  xserver-xorg-video-vesa                      1:2.3.0-5                         X.Org X server -- VESA display driver
ii  xserver-xorg-video-vmware                    1:11.0.3-2                        X.Org X server -- VMware display driver
ii  xserver-xorg-video-voodoo                    1:1.2.4-2                         X.Org X server -- Voodoo display driver
Comment 1 fhimpe 2011-04-02 18:43:11 UTC
Created attachment 53252 [details]
dmesg
Comment 2 fhimpe 2011-04-02 18:44:46 UTC
Created attachment 53262 [details]
Xorg.0.log
Comment 3 fhimpe 2011-05-16 12:01:53 UTC
This does not happen anymore with later 2.6.38.x kernels, so this seems to be fixed.
Comment 4 Florian Mickler 2011-05-17 07:47:52 UTC
Do you have the sha1 of the fix? Else we close as Unreproducible nowadays.

Note You need to log in before you can comment on or make changes to this bug.