Bug 32222 - Possible kernel panic after resume from s2disk
Possible kernel panic after resume from s2disk
Status: CLOSED CODE_FIX
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
: 32652 (view as bug list)
Depends on:
Blocks: 7216 32012
  Show dependency treegraph
 
Reported: 2011-03-30 00:03 UTC by Donald
Modified: 2011-04-16 20:07 UTC (History)
8 users (show)

See Also:
Kernel Version: 2.6.38.2
Tree: Mainline
Regression: Yes


Attachments

Description Donald 2011-03-30 00:03:04 UTC
After kernel update suspend to disk works normal, but after resuming system is unresponsive. Resume process shows on a tty, but when it hits 100% and screen clears kernel possibly crashes (cursor stays but not blinks, no any response on SysRq keys) - seems to be kernel panic occured.
Kernels prior to 2.6.38.2 works well (current - 2.6.38).
Same behavior on latest stable longterm (2.6.32.36).
Software packages:
suspend-utils 1.0
kernel 2.6.38.2
Comment 1 Rafael J. Wysocki 2011-03-30 19:49:28 UTC
Is the problem 100% reproducible?
Comment 2 Lars-Dominik Braun 2011-03-30 21:16:15 UTC
I'm experiencing the same issue here. Suspend to disk works fine for kernel versions before 2.6.38.2.

Steps to reproduce: echo disk > /sys/power/state, power on again, data is loading from swap partition (3GB, 2GB RAM), 100% loaded, screen goes black (everything's still fine), screen stays black, the two rightmost leds on my keyboard start blinking. No response to SysRq keys. No traces in the logfiles.

Out of three suspend->wake up cycles I've had this problem every time.
Comment 3 Rafael J. Wysocki 2011-03-30 22:03:54 UTC
Can you check if reverting this commit helps:

commit ff518ea26654e05d325d996f6e3a7f5f569cc2d5
Author: Yinghai Lu <yinghai@kernel.org>
Date:   Fri Feb 18 11:30:30 2011 +0000

    x86: Cleanup highmap after brk is concluded
    
    commit e5f15b45ddf3afa2bbbb10c7ea34fb32b6de0a0e upstream.

    Signed-off-by: Yinghai Lu <yinghai@kernel.org>
    Signed-off-by: Stefano Stabellini <stefano.stabellini@eu.citrix.com>
    LKML-Reference: <alpine.DEB.2.00.1103171739050.3382@kaball-desktop>
    Signed-off-by: H. Peter Anvin <hpa@zytor.com>
    Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
Comment 4 Lars-Dominik Braun 2011-03-31 10:17:34 UTC
Yes, after reverting this commit resuming from suspend to disk works again.
Comment 5 Rafael J. Wysocki 2011-03-31 21:07:48 UTC
Please check if this patch makes things work:
https://patchwork.kernel.org/patch/679502/
without reverting the above commit.
Comment 6 Donald 2011-04-01 08:06:09 UTC
(In reply to comment #5)
> Please check if this patch makes things work:
> https://patchwork.kernel.org/patch/679502/
> without reverting the above commit.

This patch solved the problem, resume works now.
Comment 7 Lars-Dominik Braun 2011-04-01 08:15:39 UTC
> This patch solved the problem, resume works now.

Same here.
Comment 8 Rafael J. Wysocki 2011-04-01 23:29:47 UTC
Patch : https://patchwork.kernel.org/patch/679502/
Handled-By : Stefano Stabellini <stefano.stabellini@eu.citrix.com>
Comment 9 Rafael J. Wysocki 2011-04-16 17:07:05 UTC
*** Bug 32652 has been marked as a duplicate of this bug. ***
Comment 10 Rafael J. Wysocki 2011-04-16 17:08:12 UTC
Fixed by commit 4da9484bdece39ab0b098fa711e095e3e9fc8684 .

Note You need to log in before you can comment on or make changes to this bug.