Bug 32112 - Writes to USB flash drives are extremely slow in 2.6.38
Writes to USB flash drives are extremely slow in 2.6.38
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: FAT/VFAT/MSDOS
All Linux
: P1 normal
Assigned To: OGAWA Hirofumi
:
Depends on:
Blocks: 27352
  Show dependency treegraph
 
Reported: 2011-03-29 08:10 UTC by Delan Azabani
Modified: 2011-05-13 00:54 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.38
Tree: Mainline
Regression: Yes


Attachments
screenshot example (12.32 KB, image/png)
2011-03-29 08:10 UTC, Delan Azabani
Details

Description Delan Azabani 2011-03-29 08:10:01 UTC
Created attachment 52422 [details]
screenshot example

Upon compiling and installing the final version of the 2.6.38 kernel, writes to USB storage have become extremely slow. I've tried all ports available on various known-working flash drives, and get speeds around 0.2MB/s rather than 5-10MB/s. I will test 2.6.37 again to make sure it's really to do with the kernel soon, when I have time.

lspci:

00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 4 Series Chipset PCI Express Root Port (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #4
00:1a.1 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #5
00:1a.2 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #6
00:1a.7 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #2
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
00:1c.0 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 1
00:1c.3 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 4
00:1c.4 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 5
00:1c.5 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 6
00:1d.0 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #1
00:1d.1 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #2
00:1d.2 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #3
00:1d.7 USB Controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #1
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 90)
00:1f.0 ISA bridge: Intel Corporation 82801JIR (ICH10R) LPC Interface Controller
00:1f.2 SATA controller: Intel Corporation 82801JI (ICH10 Family) SATA AHCI Controller
00:1f.3 SMBus: Intel Corporation 82801JI (ICH10 Family) SMBus Controller
01:00.0 VGA compatible controller: nVidia Corporation NV44 [GeForce 6200 TurboCache(TM)] (rev a1)
03:00.0 SATA controller: JMicron Technology Corp. JMB362/JMB363 Serial ATA Controller (rev 02)
03:00.1 IDE interface: JMicron Technology Corp. JMB362/JMB363 Serial ATA Controller (rev 02)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
06:07.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)

lsmod:

Module                  Size  Used by
nls_iso8859_1           4245  0 
nls_cp850               4993  0 
vfat                    8276  0 
fat                    40966  1 vfat
usb_storage            38956  0 
oss_usb               117863  0 
oss_hdaudio           144007  0 
osscore               538035  2 oss_usb,oss_hdaudio
it87                   22764  0 
coretemp                4666  0 
adt7475                16227  0 
hwmon_vid               1692  2 it87,adt7475
hwmon                   1297  3 it87,coretemp,adt7475
fuse                   55326  3 
hid_logitech            6291  0 
usbhid                 20749  0 
hid                    40047  2 hid_logitech,usbhid
raid456                43549  1 
async_pq                2268  1 raid456
async_xor               1433  2 raid456,async_pq
xor                     4385  1 async_xor
async_memcpy             982  1 raid456
async_raid6_recov       1249  1 raid456
raid6_pq               77146  2 async_pq,async_raid6_recov
async_tx                1161  5 raid456,async_pq,async_xor,async_memcpy,async_raid6_recov
raid1                  17643  1 
md_mod                 78992  6 raid456,raid1
nouveau               555242  2 
fbcon                  34504  76 
font                    7228  1 fbcon
bitblit                 4066  1 fbcon
ttm                    44101  1 nouveau
softcursor              1093  1 bitblit
drm_kms_helper         21366  1 nouveau,[permanent]
drm                   145307  4 nouveau,ttm,drm_kms_helper
agpgart                22857  2 ttm,drm
uhci_hcd               17968  0 
fb                     44606  5 nouveau,fbcon,bitblit,softcursor,drm_kms_helper
i2c_i801                6484  0 
fbdev                    673  1 fb
i2c_algo_bit            4232  1 nouveau
ehci_hcd               31172  0 
i2c_core               15315  6 adt7475,nouveau,drm_kms_helper,drm,i2c_i801,i2c_algo_bit
cfbcopyarea             2865  1 nouveau
r8169                  31361  0 
mii                     3154  1 r8169
video                  10647  1 nouveau
cfbimgblt               1873  1 nouveau
cfbfillrect             2909  1 nouveau
usbcore               103513  5 usb_storage,oss_usb,usbhid,uhci_hcd,ehci_hcd

uname:

Linux 2.6.38-gentoo-delan2 #4 SMP Sun Mar 27 07:51:18 WST 2011 x86_64 Intel(R) Core(TM)2 Quad CPU Q9650 @ 3.00GHz GenuineIntel GNU/Linux
Comment 1 Delan Azabani 2011-03-29 08:26:33 UTC
Turns out that this is a FAT-related problem, as when reformatting USB drives as ext4, there is no problem and I can reach 20MB/s writes easy, so it's not a USB problem.
Comment 2 Florian Mickler 2011-05-10 13:22:44 UTC
Is this still a problem in 2.6.39-rc7? (or 2.6.38.y)
Comment 3 Delan Azabani 2011-05-13 00:40:47 UTC
No, this doesn't appear to be a problem anymore.

Note You need to log in before you can comment on or make changes to this bug.