Bug 32102 - Spurious GPU hangups with 2.6.38
Spurious GPU hangups with 2.6.38
Status: RESOLVED DUPLICATE of bug 31102
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-29 08:05 UTC by Artem Anisimov
Modified: 2011-03-29 08:13 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.38.1
Tree: Mainline
Regression: Yes


Attachments

Description Artem Anisimov 2011-03-29 08:05:10 UTC
From time to time the screen in X freezes for a couple of seconds, then X gets killed. In dmesg I see the following:

[drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -11 (awaiting 533849 at 533847, next 533850)
[drm:i915_reset] *ERROR* Failed to reset chip.

Attempting to restart X results in blank display and completely hung X (does not even respond to Ctrl+Alt+Fn); the only way out is SysRq.

I've seen a similar bug 31102, but in my case there is no Chromium, only minimalistic KDE setup. So I believe this bug has different origin.

My HW configuration is the same as in bug 27322. I am using xf86-video-intel-2.14.0.
Comment 1 Artem Anisimov 2011-03-29 08:06:07 UTC
Forgot to add that I experienced no such hangups when running 2.6.37.
Comment 2 Chris Wilson 2011-03-29 08:13:22 UTC
Not, it's the same bug as 31102.

*** This bug has been marked as a duplicate of bug 31102 ***

Note You need to log in before you can comment on or make changes to this bug.