Bug 3203 - S3 resume: video restored only w/ NVIDIA-ACPI X driver - Samsung X30 WVC1500, Dell 8600
S3 resume: video restored only w/ NVIDIA-ACPI X driver - Samsung X30 WVC1500,...
Status: REJECTED DUPLICATE of bug 7225
Product: Drivers
Classification: Unclassified
Component: Video(Other)
i386 Linux
: P2 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-13 07:34 UTC by Christoph Tavan
Modified: 2007-04-28 12:49 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.7
Tree: Mainline
Regression: ---


Attachments
dmesg output after s3 resume (14.65 KB, text/plain)
2004-08-13 07:39 UTC, Christoph Tavan
Details
acpidmp output (75.39 KB, text/plain)
2004-08-13 07:39 UTC, Christoph Tavan
Details
dmidecode output (8.75 KB, text/plain)
2004-08-13 07:40 UTC, Christoph Tavan
Details
lspic of Samsung X30 WVC1500 (10.30 KB, text/plain)
2004-08-13 07:42 UTC, Christoph Tavan
Details
cat /proc/interrupts (337 bytes, text/plain)
2004-08-13 07:52 UTC, Christoph Tavan
Details
Photo of Display after S3 resume with video_post (25.05 KB, image/jpeg)
2004-11-14 14:09 UTC, Christoph Tavan
Details

Description Christoph Tavan 2004-08-13 07:34:52 UTC
Distribution: gentoo-dev-sources-2.6.7-r11 
Hardware Environment: Samsung X30 WVC1500 laptop 
Software Environment: Gentoo linux. Kernel 2.6.7 with latest 
acpi-20040715-2.6.7-patch from acpi.sf.net applied. 
Problem Description: Laptop suspends and wakes up properly (after wakeup I can 
connect via ssh!) but the display remains black (no matter, whether I was in 
X, framebuffer or text-mode). Tips 
from /usr/src/linux/Documentation/power/video.txt didn's help. 
 
Steps to reproduce: echo -n mem > /sys/power/state 
Then press the Powerbutton.
Comment 1 Christoph Tavan 2004-08-13 07:39:13 UTC
Created attachment 3500 [details]
dmesg output after s3 resume
Comment 2 Christoph Tavan 2004-08-13 07:39:51 UTC
Created attachment 3501 [details]
acpidmp output
Comment 3 Christoph Tavan 2004-08-13 07:40:26 UTC
Created attachment 3502 [details]
dmidecode output
Comment 4 Christoph Tavan 2004-08-13 07:42:12 UTC
Created attachment 3503 [details]
lspic of Samsung X30 WVC1500
Comment 5 Christoph Tavan 2004-08-13 07:52:27 UTC
Created attachment 3504 [details]
cat /proc/interrupts
Comment 6 thomas 2004-08-25 04:00:36 UTC
I have the exact same symptoms with my Dell Inspiron 8600 w/WUXGA display
and GeForce FX Go 5200 adapter.
Using Fedora Core 2, tried a handful of kernels, including 2.6.8.1
w/acpi-20040715 patch, and plain 2.6.9-rc1. Also tried 'xset dpms force off'
before entering S3, with no success.
Comment 7 Christian Hesse 2004-08-28 15:58:28 UTC
Same here with X10.

However, this program [1] activates the display, but it's still not usable.

[1] http://www.doesi.gmxhome.de/linux/tm800s3/resources/boot-radeon.c
Comment 8 thomas 2004-08-29 23:18:57 UTC
I finally resolved my case. By uising a newer NVIDIA X-driver which supports ACPI,
S3 suspending works perfectly (only from X, though). Maybe there's a driver for
the Radeon card supporting ACPI as well?
Comment 9 Len Brown 2004-11-04 00:57:46 UTC
Christoph, is the Samsung fixed as the Dell was with an updated NVIDIA driver?
Christian, how abou the X10?

If it works in X, will virtual consoles still work after resume?
Comment 10 thomas 2004-11-04 01:05:24 UTC
Len -- yes, virtual consoles work fine after S3 resume here.
Comment 11 Christoph Tavan 2004-11-14 03:19:18 UTC
Hi Len, 
I tried it with the latest nvidia-drivers 1.0.6629 but I had no success: 
The display still remains black after S3 resume no matter whether I suspended 
it from X, fb-console or text-console. In the case where I suspend it from the 
console I can type "reboot" after resume and it reboots properly. Everything 
seems to work after resume except the display. 
I'm using 2.6.9 sources (gentoo-dev-sources-2.6.9-r1) at the moment. 
Any other Ideas? 
Thanks, Christoph 
Comment 12 Venkatesh Pallipadi 2004-11-14 10:06:46 UTC
Can you check whether running the video_post utility from bug #3670 changes 
anything? Please try it from VGA console with no framebuffer.
Comment 13 Christoph Tavan 2004-11-14 14:09:23 UTC
Created attachment 4029 [details]
Photo of Display after S3 resume with video_post

As you suggested, Venki, I've tried your tool from the vga-console (and from
the fb-console as well). Yeah, it did some kind of reactivate the display. But
the display got white and then slowly turned to gray with some funny colored
stipes (see attachment)...
Christoph
Comment 14 thomas 2005-04-11 04:30:46 UTC
(Len,) It turns out my virtual consoles do not work after resume after all.
Sorry for this late feedback. I'm now on 2.6.9/fc2 and nvidia driver 1.0.6629.
Comment 15 Jakob Schi 2005-06-17 01:05:56 UTC
I have the same problem with my Dell Inspiron 5150 laptop with A38 bios, the
2.6.11-gentoo-r11 kernel (essentially a 2.6.11.12 kernel) and binary-only NVIDIA
driver version 1.0.7664.  Suspend works if X is running (a part from the USB
devices sometimes getting lost, and the fan running a bit fast afterwards), but
all virtual consoles are messed up.  If X was the active display the LCD display
is filled with weird colors once I shift to a virtual console.  If I was on a
virtual console, it is black.  A part from this the computer is working.

/Jakob
Comment 16 C. Gr 2006-02-20 05:47:26 UTC
I have the same problem with my Samsung M40 and Ubuntu 5.10.
The display remains black after resume. From the console
it can be reactivated by vbetool's post comand. Then it shows the
strange behaviour described above.
Comment 17 Len Brown 2006-08-09 20:36:43 UTC
Video restore on S3 resume is the job of the BIOS or video driver,
and is not part of ACPI.  Moving to drivers/video.
Comment 18 Rafael J. Wysocki 2006-09-28 10:06:39 UTC
Problems with video after an S3 resume can be solved by the s2ram tool (see
http://en.opensuse.org/S2ram).  If that helps, please close this bug.
Comment 19 Rafael J. Wysocki 2006-09-28 10:31:44 UTC

*** This bug has been marked as a duplicate of 7225 ***

Note You need to log in before you can comment on or make changes to this bug.