Bug 3201 - linux-2.6.8-rc4-mm1: IPv6-in-IPv6 undefined references
linux-2.6.8-rc4-mm1: IPv6-in-IPv6 undefined references
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Networking
Classification: Unclassified
Component: IPV6
i386 Linux
: P2 blocking
Assigned To: Adrian Bunk
:
: 3200 3216 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-12 14:59 UTC by Ioannis Aslanidis
Modified: 2004-09-21 00:19 UTC (History)
0 users

See Also:
Kernel Version: linux-2.6.8-rc4-mm1
Tree: Mainline
Regression: ---


Attachments

Description Ioannis Aslanidis 2004-08-12 14:59:12 UTC
Distribution: Gentoo GNU/Linux
Hardware Environment: i686 (Athlon XP)
Software Environment: 
Portage 2.0.50-r9 (default-x86-2004.2, gcc-3.3.4, glibc-2.3.4.20040808-r0,
2.6.7-gentoo-r12)
=================================================================
System uname: 2.6.7-gentoo-r12 i686 AMD Athlon(tm) XP 1800+
Gentoo Base System version 1.5.2
distcc 2.16 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1

Problem Description:
There seems to be a problem either compiling built-in or as a module the
IPv6-in-IPv6 tunnel option:

<*> The IPv6 protocol (EXPERIMENTAL)
     <M>   IPv6: IPv6-in-IPv6 tunnel



As module:

**********
make[1]: `arch/i386/kernel/asm-offsets.s' is up to date.
  CHK     include/linux/compile.h
Kernel: arch/i386/boot/bzImage is ready
  Building modules, stage 2.
  MODPOST
*** Warning: "xfrm6_tunnel_deregister" [net/ipv6/ip6_tunnel.ko] undefined!
*** Warning: "xfrm6_tunnel_register" [net/ipv6/ip6_tunnel.ko] undefined!
make[1]: `arch/i386/kernel/asm-offsets.s' is up to date.
  CHK     include/linux/compile.h
Kernel: arch/i386/boot/bzImage is ready
  Building modules, stage 2.
  MODPOST
*** Warning: "xfrm6_tunnel_deregister" [net/ipv6/ip6_tunnel.ko] undefined!
*** Warning: "xfrm6_tunnel_register" [net/ipv6/ip6_tunnel.ko] undefined!
  INSTALL drivers/ide/ide-floppy.ko
  INSTALL drivers/net/dummy.ko
  INSTALL drivers/pci/hotplug/cpqphp.ko
  INSTALL drivers/pci/hotplug/fakephp.ko
  INSTALL drivers/pci/hotplug/ibmphp.ko
  INSTALL drivers/pci/hotplug/pci_hotplug.ko
  INSTALL drivers/pci/hotplug/pciehp.ko
  INSTALL drivers/pci/hotplug/shpchp.ko
  INSTALL drivers/scsi/osst.ko
  INSTALL drivers/scsi/sd_mod.ko
  INSTALL drivers/scsi/st.ko
  INSTALL drivers/usb/host/ehci-hcd.ko
  INSTALL drivers/usb/host/ohci-hcd.ko
  INSTALL drivers/usb/storage/usb-storage.ko
  INSTALL net/bluetooth/hidp/hidp.ko
  INSTALL net/ipv6/ip6_tunnel.ko
if [ -r System.map ]; then /sbin/depmod -ae -F System.map  2.6.8-rc4-mm1; fi
WARNING: /lib/modules/2.6.8-rc4-mm1/kernel/net/ipv6/ip6_tunnel.ko needs unknown
symbol xfrm6_tunnel_register
WARNING: /lib/modules/2.6.8-rc4-mm1/kernel/net/ipv6/ip6_tunnel.ko needs unknown
symbol xfrm6_tunnel_deregister
**********

Built-in:

**********
  SPLIT   include/linux/autoconf.h -> include/config/*
make[1]: `arch/i386/kernel/asm-offsets.s' is up to date.
  CHK     include/linux/compile.h
  GZIP    kernel/config_data.gz
  IKCFG   kernel/config_data.h
  CC      kernel/configs.o
  LD      kernel/built-in.o
  CC      net/ipv6/af_inet6.o
  LD      net/ipv6/ipv6.o
  CC      net/ipv6/ip6_tunnel.o
  LD      net/ipv6/built-in.o
  LD      net/built-in.o
  GEN     .version
  CHK     include/linux/compile.h
  UPD     include/linux/compile.h
  CC      init/version.o
  LD      init/built-in.o
  LD      .tmp_vmlinux1
net/built-in.o(.init.text+0x37e7): In function `ip6_tunnel_init':
: undefined reference to `xfrm6_tunnel_register'
net/built-in.o(.init.text+0x3846): In function `ip6_tunnel_init':
: undefined reference to `xfrm6_tunnel_deregister'
net/built-in.o(.exit.text+0x926): In function `ip6_tunnel_cleanup':
: undefined reference to `xfrm6_tunnel_deregister'
make: *** [.tmp_vmlinux1] Error 1
**********

Reproducible: Always
Steps to Reproduce:
1. Select IPv6-in-IPv6 tunnel support for linux kernel 2.6.8-rc4-mm1
2. make

Actual Results:  
Image fails when selecting it built-in.
Compiling as a module fails too.

In both cases, there are undefined references.


References: http://bugs.gentoo.org/show_bug.cgi?id=60133
Comment 1 Ioannis Aslanidis 2004-08-12 14:59:57 UTC
*** Bug 3200 has been marked as a duplicate of this bug. ***
Comment 2 Ioannis Aslanidis 2004-08-15 02:51:32 UTC
I have compiled kernel 2.6.8 with the same problems in the same module:

# make  && make bzImage modules modules_install
make[1]: `arch/i386/kernel/asm-offsets.s' is up to date.
  CHK     include/linux/compile.h
  GEN     .version
  CHK     include/linux/compile.h
  UPD     include/linux/compile.h
  CC      init/version.o
  LD      init/built-in.o
  LD      .tmp_vmlinux1
net/built-in.o(.init.text+0x37e7): In function `ip6_tunnel_init':
: undefined reference to `xfrm6_tunnel_register'
net/built-in.o(.init.text+0x3846): In function `ip6_tunnel_init':
: undefined reference to `xfrm6_tunnel_deregister'
net/built-in.o(.exit.text+0x926): In function `ip6_tunnel_cleanup':
: undefined reference to `xfrm6_tunnel_deregister'
make: *** [.tmp_vmlinux1] Error 1
Comment 3 Adrian Bunk 2004-09-01 12:40:37 UTC
This bug should be fixed in 2.6.9-rc1.

If you can still reproduce this bug in 2.6.9-rc1, please attach your .config .
Comment 4 Adrian Bunk 2004-09-01 12:42:38 UTC
*** Bug 3216 has been marked as a duplicate of this bug. ***
Comment 5 Hideaki YOSHIFUJI 2004-09-21 00:11:34 UTC
Already fixed. This bug should be closed. Thanks.
Comment 6 Adrian Bunk 2004-09-21 00:19:56 UTC
Thanks for this information, I'm therefore closing this bug.

Note You need to log in before you can comment on or make changes to this bug.