Bug 31982 - XFS memory allocation deadlock in 2.6.38
Summary: XFS memory allocation deadlock in 2.6.38
Status: CLOSED CODE_FIX
Alias: None
Product: File System
Classification: Unclassified
Component: XFS (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: XFS Guru
URL:
Keywords:
Depends on:
Blocks: 27352
  Show dependency tree
 
Reported: 2011-03-27 18:10 UTC by Maciej Rutecki
Modified: 2011-05-01 14:44 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.38
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-03-27 18:10:10 UTC
Subject    : XFS memory allocation deadlock in 2.6.38
Submitter  : Sean Noonan <Sean.Noonan@twosigma.com>
Date       : 2011-03-21 16:19
Message-ID : 081DDE43F61F3D43929A181B477DCA95639B52FD@MSXAOA6.twosigma.com
References : http://marc.info/?l=linux-kernel&m=130072585111310&w=2

This entry is being used for tracking a regression from 2.6.37. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Florian Mickler 2011-05-01 14:37:42 UTC
Patch: http://marc.info/?l=linux-xfs&m=130144519123809&w=2

Merged in v2.6.39-rc3 as:

commit e828776a8abe6b9bae7ed9638710bff7642c568a
Author: Dave Chinner <dchinner@redhat.com>
Date:   Fri Apr 8 12:45:07 2011 +1000

    xfs: fix extent format buffer allocation size

Note You need to log in before you can comment on or make changes to this bug.