Bug 31892 - Problems with nouveau on my HP laptop
Summary: Problems with nouveau on my HP laptop
Status: RESOLVED OBSOLETE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-26 03:04 UTC by Larry Finger
Modified: 2012-08-20 15:17 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.38-Linus-07088-gb973a3b
Tree: Mainline
Regression: No


Attachments

Description Larry Finger 2011-03-26 03:04:29 UTC
First of all, this is not a complaint. Using 2.6.38-gitX, my laptop works correctly using the nouveau driver, at least for X. I previously tried it with the 2.6.37 kernel in openSUSE 11.4. At that point, nothing worked. I congratulate you on your improvements.

My hardware is given by "sudo lspci -vvv" as

00:12.0 VGA compatible controller: nVidia Corporation C67 [GeForce 7150M / nForce 630M] (rev a2) (prog-if 00 [VGA controller])
        Subsystem: Hewlett-Packard Company Device 30d6
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 22
        Region 0: Memory at f4000000 (32-bit, non-prefetchable) [size=16M]
        Region 1: Memory at d0000000 (64-bit, prefetchable) [size=256M]
        Region 3: Memory at f0000000 (64-bit, non-prefetchable) [size=16M]
        [virtual] Expansion ROM at c0000000 [disabled] [size=128K]
        Capabilities: [48] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
                Address: 0000000000000000  Data: 0000
        Kernel driver in use: nouveau

The probllems are as follows:

(1) My logs are spammed with lots of

[drm] nouveau 0000:00:12.0: Load detected on output B

There are also the occasional

[drm] nouveau 0000:00:12.0: Setting dpms mode 0 on lvds encoder (output 0)
[drm] nouveau 0000:00:12.0: Calling LVDS script 2:
[drm] nouveau 0000:00:12.0: 0xD6D8: Parsing digital output script table
[drm] nouveau 0000:00:12.0: Calling LVDS script 5:
[drm] nouveau 0000:00:12.0: 0xD676: Parsing digital output script table
[drm] nouveau 0000:00:12.0: Setting dpms mode 0 on TV encoder (output 2)

(2) The fonts in terminals are not really sharp. The screen resolution is set to 1024x768, not the 1280x800 that is native for the screen. The xrandr command shows

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 4096 x 4096
LVDS-1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 303mm x 190mm
   1280x800       60.0 +
   1024x768       59.9* 
   800x600        59.9  
   640x480        59.4  
   720x400        59.6  
   640x400        60.0  
   640x350        59.8  

The inability to switch to the higher resolution is probably my fault.

The worst problem is that the boot sequence and virtual terminals 1-6 all have the text covering only the right-hand 2/3 of the screen, and the characters are not dense as they are with the framebuffer driver I get with the "nomodeset" option on the GRUB boot line.
Comment 1 Marcin Slusarz 2011-03-26 13:26:43 UTC
Please note that nouveau bugs are generally handled in freedesktop.org bugzilla (see http://nouveau.freedesktop.org/wiki/Bugs ), so updates to this bug report might pass unnoticed.

Anyhow, check whether some symptoms will disappear if you pass video=TV-1:d in kernel command line and attach complete kernel and Xorg log.

Note You need to log in before you can comment on or make changes to this bug.