Bug 31862 - [gm45] White text blocks shown during boot-up
Summary: [gm45] White text blocks shown during boot-up
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel) (show other bugs)
Hardware: All Linux
: P3 normal
Assignee: intel-gfx-bugs@lists.freedesktop.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-24 23:46 UTC by Sebastian Pipping
Modified: 2014-09-18 13:41 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.15
Tree: Mainline
Regression: No


Attachments
Boot screenshot showing white boxes (99.23 KB, image/jpeg)
2011-03-24 23:46 UTC, Sebastian Pipping
Details
Output of "dmesg | fgrep drm" from Linux 3.12.5 (80.70 KB, text/plain)
2014-02-10 13:21 UTC, Sebastian Pipping
Details

Description Sebastian Pipping 2011-03-24 23:46:21 UTC
Created attachment 51942 [details]
Boot screenshot showing white boxes

This is my first bug report up here, please bare with me.

I get these white boxes (see screenshot) when booting from an initramfs generated by Dracut 008 on Gentoo.  Dracut upstream suspect a problem outside dracut.  While I normally do use a Gentoo-modified kernel, vanilla Linux 2.6.38 shows the same behavior.

Is there anything I can do?
Comment 1 Sebastian Pipping 2011-07-13 20:14:05 UTC
Bug persists with 2.6.39.3.  Happens without Dracut, too.

My active graphics card is the Intel one of these:

# sudo lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3400 Series
Comment 2 Sebastian Pipping 2012-08-20 21:03:41 UTC
Excuse me, I am re-opening because:
- The problem persist in recent kernels.
- No explanation was given why the bug is invalid.

If you close as invalid again, please help me understand why.  Thanks!
Comment 3 Alan 2012-08-20 21:14:47 UTC
Because nothing had happened since 2011 and because it appeared to be to do with the userspace. Just having a general prune of old bugs - not particularly picking on yours

Now it's re-opened and known current hopefully it'll shake a branch or two.

Do you only see the white rectangles during dracut or do they appear in X or console too ?
Comment 4 Michel Dänzer 2012-08-21 08:14:28 UTC
(In reply to comment #1)
> My active graphics card is the Intel one of these:

Alan, I think you picked the wrong component.
Comment 5 Alan 2012-08-21 09:12:58 UTC
Indeed - moved. And that would make more sense as there is another 'squares' report. in i915 space.
Wonder if someone isn't always clearing up sprites and overlays  ?
Comment 6 Sebastian Pipping 2012-08-24 23:26:02 UTC
(In reply to comment #3)
> Now it's re-opened and known current hopefully it'll shake a branch or two.

Great to see some action.


> Do you only see the white rectangles during dracut or do they appear in X or
> console too ?

Only at the first few console lines flying by long.  Happens with dracut and/or genkernel.  No issues in X.
Comment 7 Daniel Vetter 2012-11-13 11:30:06 UTC
Is this still an issue on latest kernels? Tbh it looks like something in fbcon doesn't properly draw stuff - the other white box bug looks quite a bit different.
Comment 8 Sebastian Pipping 2012-11-17 00:35:03 UTC
(In reply to comment #7)
> Is this still an issue on latest kernels?

Yes, the issue persists with Linux 3.6.6.
Comment 9 Daniel Vetter 2013-01-16 14:30:57 UTC
Worth retesting with 3.8-rc kernels - the takeover sequence from the BIOS config is markedly different, and we've fixed a few "dirt in framebuffer" issues.
Comment 10 Sebastian Pipping 2013-01-19 22:02:06 UTC
(In reply to comment #9)
> Worth retesting with 3.8-rc kernels

Just tried 3.8-rc3, the very latest by the time of your last reply.
The bug persists with 3.8-rc3.  I can give 3.8-rc4 a spin too, if you wish.
Comment 11 Sebastian Pipping 2013-02-10 21:51:48 UTC
Please re-open, the requested info has been provided.
Comment 12 Jani Nikula 2013-04-10 18:13:45 UTC
Very similar to bug 17121.
Comment 13 Sebastian Pipping 2013-04-10 19:02:49 UTC
Could you re-open this bug?  It's still marked NEEDINFO despite all info being provided by now.  Thanks!
Comment 14 Jani Nikula 2013-04-29 05:32:15 UTC
Is this fixed in 3.9, specifically by

commit 88afe715dd5469bc24ca7a19ac62dd3c241cab48
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Sun Dec 16 12:15:41 2012 +0000

    drm/i915: Clear the stolen fb before enabling
Comment 15 Sebastian Pipping 2013-05-01 22:06:05 UTC
(In reply to comment #14)
> Is this fixed in 3.9

Sadly not, issue persist with 3.9.0.
Comment 16 Jani Nikula 2013-12-12 13:45:42 UTC
It seems nobody has any ideas. I can only ask if the issue is still present in 3.12?
Comment 17 Sebastian Pipping 2013-12-15 16:59:20 UTC
(In reply to Jani Nikula from comment #16)
> It seems nobody has any ideas. I can only ask if the issue is still present
> in 3.12?

Running vanilla 3.12.5 now, issue persists :(
Comment 18 Jani Nikula 2014-02-04 18:47:55 UTC
No real ideas, but

1) Please provide a dmesg of the boot, with drm.debug=0xe module parameter.

2) Please boot without i915 or i915 blacklisted with modprobe.blacklist=i915
Comment 19 Sebastian Pipping 2014-02-10 13:21:46 UTC
Created attachment 125511 [details]
Output of "dmesg | fgrep drm" from Linux 3.12.5

(In reply to Jani Nikula from comment #18)
> 1) Please provide a dmesg of the boot, with drm.debug=0xe module parameter.

Attached.

It's from Linux 3.12.5.  I applied filter "fgrep drm" to mitigate potential privacy issues.  If that's an issue, I could send the unfiltered log to you directly or something.
Comment 20 Daniel Vetter 2014-02-11 10:35:51 UTC
Sounds like something that Jesse's fb takeover patch might fix. If not then it's the hilarious fail called vgacon->fbcon takeover, which is unlikely to ever get fixed (because *shudder*).
Comment 21 Sebastian Pipping 2014-02-11 19:54:16 UTC
(In reply to Jani Nikula from comment #18)
> 2) Please boot without i915 or i915 blacklisted with modprobe.blacklist=i915

Without i915 it doesn't switch to higher resolution and seems to hang somewhere before disk encryption wants my password.  With i915 back in, boot goes well as usual.  Now speaking of 3.13.2.

How do we proceed?
Comment 22 Sebastian Pipping 2014-02-21 23:41:20 UTC
Can we turn NEEDINFO back to ASSIGNED?  Do you need something more?
Comment 23 Daniel Vetter 2014-03-03 13:34:35 UTC
I think it'd be good if you can test Jesse's latest patches a bit. There's still a few missing pieces which aren't yet merged ...

Jesse can you please proved a branch somewhere?
Comment 24 Jesse Barnes 2014-03-03 16:10:15 UTC
Latest bits are in the inherit-bios branch of git://people.freedesktop.org/~jbarnes/linux.
Comment 25 Sebastian Pipping 2014-03-07 16:18:36 UTC
(In reply to Jesse Barnes from comment #24)
> Latest bits are in the inherit-bios branch of
> git://people.freedesktop.org/~jbarnes/linux.

Presents to me as 3.13.0+, same white boxes during start-up.
Comment 26 Daniel Vetter 2014-03-27 22:24:20 UTC
Jesse' patches have been merged to drm-intel-nightly for 3.15. Presumably fixed by those, please reopen if that's not the case.
Comment 27 Sebastian Pipping 2014-04-13 20:55:50 UTC
(In reply to Daniel Vetter from comment #26)
> Jesse' patches have been merged to drm-intel-nightly for 3.15. Presumably
> fixed by those, please reopen if that's not the case.

Just tried drm-intel-nightly (commit 8f5284d0165252f41609a97acc2755234b22cf15): still showing white boxes.  Re-opening.
Comment 28 Daniel Vetter 2014-05-19 20:01:18 UTC
Can you please retest with 3.15-rc? That has the fb takeover patches from Jesse (finally!) and might actually help this time around.
Comment 29 Sebastian Pipping 2014-06-13 19:37:43 UTC
(In reply to Daniel Vetter from comment #28)
> Can you please retest with 3.15-rc? That has the fb takeover patches from
> Jesse (finally!) and might actually help this time around.

Running 3.15.0 by now: still showing white blocks.

Please revert from needinfo to re-opened (and from P3 to P1 if it was for my delay in replying).
Comment 30 Jani Nikula 2014-06-16 12:51:54 UTC
(In reply to Sebastian Pipping from comment #29)
> Please revert from needinfo to re-opened (and from P3 to P1 if it was for my
> delay in replying).

We defaulted all non-regressions to P3.
Comment 31 Jani Nikula 2014-09-12 08:55:57 UTC
Sadly, I can only ask you to try a recent kernel. We may have fixed the bug, but we're quite obviously clueless about any of our fixes having a connection to this particular bug.
Comment 32 Sebastian Pipping 2014-09-17 22:50:56 UTC
If I can trust my eyes the white blocks are gone in 3.16.2.
Comment 33 Jani Nikula 2014-09-18 10:27:27 UTC
(In reply to Sebastian Pipping from comment #32)
> If I can trust my eyes the white blocks are gone in 3.16.2.

I'll quickly close this one before you have more doubts about your eyes. Fingers crossed. Thanks for bearing with us.
Comment 34 Sebastian Pipping 2014-09-18 13:41:08 UTC
:)  Many thanks for the fix!

Note You need to log in before you can comment on or make changes to this bug.