Bug 3168 - S1, S3 resume hang - Inspiron 8500
Summary: S1, S3 resume hang - Inspiron 8500
Status: REJECTED DUPLICATE of bug 3670
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Len Brown
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-08-06 06:37 UTC by Simon
Modified: 2004-11-04 11:54 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.7
Tree: Mainline
Regression: ---


Attachments
Output of lspci (1.24 KB, text/plain)
2004-08-06 06:38 UTC, Simon
Details

Description Simon 2004-08-06 06:37:17 UTC
Distribution: Fedora Core 2
Hardware Environment: Dell Inspiron 8500
Software Environment: gcc 3.3.3
Problem Description:

Resuming from suspend (s1 or s3) results in the system freezing.
The last output i see is this;

PM: Finishing up.
ACPI: PCI interrupt 0000:00:1d.0[A] -> GSI 11 (level, low) -> IRQ 11
PCI:: Setting letency timer of device 0000:00:1d.0 to 64
ACPI: PCI interrupt 0000:00:1d.1[B] -> GSI 11 (level, low) -> IRQ 11
PCI:: Setting letency timer of device 0000:00:1d.1 to 64
ACPI: PCI interrupt 0000:00:1d.2[C] -> GSI 11 (level, low) -> IRQ 11
PCI:: Setting letency timer of device 0000:00:1d.2 to 64


To enter suspend, i boot into runlevel 3, and remove ehci_hcd and uhci_hcd
modules and disable and remove networking modules and services.

then enter suspend using

echo "1" > /proc/acpi/sleep

Suspend works fine, however on resume it hangs.

I have tried the kernels that are supplied with fedora, and I have tried running
kernel 2.6.7 + the 20040715-2.6.7 acpi patch with no sucess.

S1 did used to work when running the 2.4 kernels from fedora core 1.

Steps to reproduce:
1) Boot into run level 3 (without framebuffer mode)
2) remove uhci_hcd and ehci_hcd modules
3) disable network services
4) remove network modules
5) echo "1" > /proc/acpi/sleep
6) Press power button to resume.
then System freeze
Comment 1 Simon 2004-08-06 06:38:42 UTC
Created attachment 3479 [details]
Output of lspci
Comment 2 Len Brown 2004-11-04 00:44:36 UTC
Latest BIOS on this system?
same result with linux-2.6.9 + acpi patch?
Comment 3 Simon 2004-11-04 02:41:25 UTC
Running with bios A06 and kernel 2.6.9 + acpi_patch fixes the problem with S1
freezing. I can now suspend and resume ok.

S3 now also resumes, however the display stays off. However i can log in remotely.
 Trying different acpi_sleep options resulted in the system rebooting on resume.
Comment 4 Venkatesh Pallipadi 2004-11-04 06:57:22 UTC
Can you also 
- Try the workaround in bug #3670

And try not using X or the framebuffer.
Use VGAtext console (deCONFIGure framebuffer in your kernel).
Comment 5 Simon 2004-11-04 07:31:31 UTC
I had already tried the console w/out framebuffer with no luck.

The video_post program now turns the display back on. It now seems that
something breaks X; it runs at 99.9% cpu usage and fails to display. No console
terminals are available either. 

Remote logging in to kill -9 X fixes this.

video_post in just the console seems ok.

Comment 6 Venkatesh Pallipadi 2004-11-04 10:21:19 UTC
OK Then. This bug can be marked duplicate of #3670.

Please look at the latest comment on bug #3670. That should help you get the X 
working after resume.
Comment 7 Len Brown 2004-11-04 11:54:52 UTC

*** This bug has been marked as a duplicate of 3670 ***

Note You need to log in before you can comment on or make changes to this bug.