Bug 31402 - Diminished brightness at startup
Summary: Diminished brightness at startup
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-dri-intel@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks: 27352
  Show dependency tree
 
Reported: 2011-03-18 16:29 UTC by Guilherme Salazar
Modified: 2012-04-18 21:05 UTC (History)
7 users (show)

See Also:
Kernel Version: 2.6.38
Tree: Mainline
Regression: Yes


Attachments

Description Guilherme Salazar 2011-03-18 16:29:12 UTC
Hi,
I've installed the latest kernel version to test the news. But I've a problem with this version.
When I turn on my laptop the brightness appears diminished. If I go to the bios setup and restart, everything works fine.
Now I'm using version 2.6.37.4 without any problem.

So, I don't know what information details do you need to help me. But the video device is a Intel Integrated Graphics (i5 series), and the module is the i915.
If additional information is needed, I'll send it.

Thank you very much for your attention.
Sorry for my poor english.
Comment 1 Matthew Garrett 2011-03-18 21:36:05 UTC
I suspect this was the change to the combined mode backlight handling - I think it's a problem with i915 rather than anything in the general backlight or acpi code.
Comment 2 Guilherme Salazar 2011-03-20 14:28:34 UTC
Does anyone have any idea that might help?
I'm using a DELL Inspiron 15R Laptop, and as I said a Intel Integrated Graphics (Processor Intel Core i5).

I'm excited to test the news of this version.
Thank you! :)
Comment 3 Rafael J. Wysocki 2011-03-27 22:59:46 UTC
On Monday, March 28, 2011, Guilherme Salazar wrote:
> Hello,
> first I would like to thank everyone who work in kernel development.
> 
> I've installed the version 2.6.38 and this bug appears. After a lot of
> trying,
> I've installed back the version 2.6.37-4. On last week, I installed the
> new 2.6.38-1, and the bug remains. Now I'm running the 2.6.37-5 with no
> problem.
Comment 4 Guilherme Salazar 2011-03-28 03:03:30 UTC
Still in 2.6.38-2.

I am ready to help you find the problem. Just tell me what to do.
I suspect that I'm doing something wrong way.
I'll compile again and post results here.


Good week for all.
Comment 5 Guilherme Salazar 2011-04-01 04:18:06 UTC
Hello.
Like I said, I've tested it again and the problem wasn't solved, unfortunately. Is it possible that it is because I'm using a config file of 2.6.37 version?



Cheers! :)
Comment 6 Guilherme Salazar 2011-04-01 05:03:00 UTC
An interesting detail is that even with this problem the function keys work. Thus, I can change the brightness during boot. I've tested now with 2.6.39-rc1 too.
Comment 7 Guilherme Salazar 2011-05-02 22:55:57 UTC
I have tested 2.6.38.5 and the problem stills chasing me.
Comment 8 Florian Mickler 2011-05-10 18:25:47 UTC
Maybe you are hitting the same issue as bug #31522 ? 
So you could try the patch from https://patchwork.kernel.org/patch/743162/
and see if it works for you too.
Comment 9 Guilherme Salazar 2011-05-11 03:37:51 UTC
Hi Florian,
I've tested it, but doesn't work for me.

Thanks anyway.
Comment 10 Daniel Vetter 2012-03-25 13:36:43 UTC
Please retest with 3.3 and report back whether this is still an issue for you. Thanks.
Comment 11 Jesse Barnes 2012-04-18 21:05:34 UTC
Please re-open if this is still an issue.

Note You need to log in before you can comment on or make changes to this bug.