Bug 3117 - (snd_)opl3sa2 (isa) doesn't work (fails on playback)
(snd_)opl3sa2 (isa) doesn't work (fails on playback)
Status: REJECTED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: PNP
i386 Linux
: P2 normal
Assigned To: Adam Belay
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-24 16:01 UTC by Ivan Kalvachev
Modified: 2007-12-03 06:12 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.10; 2.6.7; 2.6.8rc1; 2.6.5
Tree: Mainline
Regression: ---


Attachments
archive containing more detailed system info (36.85 KB, application/octet-stream)
2004-07-24 16:04 UTC, Ivan Kalvachev
Details

Description Ivan Kalvachev 2004-07-24 16:01:19 UTC
Distribution: Slackware 10
Hardware Environment:
  MB: Abit KT7A , 1GHz Athlon
  Sound: Yamaha 719 SaX (opl3sa2) ISA

Software Environment:
ALSA dirvers from the kernel and latest ALSA 1.0.5a (all compiled from source)

Problem Description:

It doesn't work. Module loads without error. On `aplay samle.wav` I got
"ALSA /work/install/alsa-driver-1.0.5a/alsa-kernel/core/pcm_lib.c:2172: playback
write error (DMA or IRQ trouble?"

I have build in isapnp support.

I also tried the manual way (pnpdump and isapnp and then specifi resources on
modprobe) that worked back on 2.2.x kernels. No luck.

alsaconf doesn't find pnp cards and bruteforce fails. Under 2.4.26 it does find
the sound card as pnp and run it perfectly fine.

I have ACPI disabled (at compile time and in lilo with "acpi=off"). This is why
this bug is different than this one http://bugzilla.kernel.org/show_bug.cgi?id=135

I tried OSS modules. No luck. 

It also may be some isa problem coz i2c isa modules also don't work, this way
putting the whole isa support under question.


Steps to reproduce:
I have attached an archive with copy of most interesting files found in /proc
and sys/, output of pnpdump (before and after module insertion), full log
output, and of course .config file i build my last kernel from.


Flame:

I want /proc/isapnp BACK. /proc/pci and /proc/isapnp comes very handy at install
time to quick check what hardware you have. Adding more programs on boot floppy
is not good idea!!!
I donno the reasons /proc/isapnp have been removed. The Documentation/isapnp.txt
forwards explainetions to pnp.txt, but there I could find only some kind of
delusions about driverfs (Is that early stage of sysfs? It don't have same tree
structure!)

Expect more flames if nobody look at the bug ;)
Comment 1 Ivan Kalvachev 2004-07-24 16:04:43 UTC
Created attachment 3423 [details]
archive containing more detailed system info

 - Output of `pnpdump` before and after modprobe snd_opl3sa2 (they are the
same)
 - Full log (sys,debug,message) from the boot of the system to the failed
playing.
 - Copy of the proc/ and sys/ files that I hope may come handy(including
cpu,pci). They are taken after failed sound play.
 - The .config file I build the kernel from.
Comment 2 Hilbert Schraal 2004-08-22 07:50:25 UTC
I have the same problem with kernel 2.6.3 on a Toshiba Tecra 8000 laptop. 
(Mandrake 10.0) 
Comment 3 Adrian Bunk 2005-07-31 12:27:25 UTC
This bug has been forwarded to the ALSA BTS:
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=879
Comment 4 Jaroslav Kysela 2005-08-09 03:29:40 UTC
It's not an ALSA bug - as you can see in the ALSA BTS. The BIOS must be set to
'PNP OS = YES'.
Comment 5 Natalie Protasevich 2007-09-08 23:52:57 UTC
Has the issue been resolved? Ivan, have you been able to follow directions in #5?
Thanks.
Comment 6 Natalie Protasevich 2007-09-08 23:53:35 UTC
... I mean #4, sorry.
Comment 7 Ivan Kalvachev 2007-09-17 05:14:57 UTC
If you take a closer look at the alsa-project bugtracker you'll see that I am the one who submitted the bug there and I am the one who found this "workaround".

I have no idea if the bug have been fixed in recent kernels (not likely) and it is not so easy to check it ATM. If you insist I'd find the isa card and plug it into my old box.
Comment 8 Natalie Protasevich 2007-09-17 22:01:53 UTC
Yes please :) I'm also copying to Bjorn, in case there is a discussion about PnP support today.
Comment 9 Bjorn Helgaas 2007-09-18 09:48:30 UTC
It works with "PNP OS = YES", but doesn't work with "PNP OS = NO".
If you can collect the dmesg and /sys contents with both BIOS settings,
I'll try to figure out what the difference is.
Comment 10 Ivan Kalvachev 2007-12-03 06:12:46 UTC
I was finally able to find the card and plug it for testing. I did collect the logs. Then I looked at them by myself and tried to figure out what's different.
I tried to load opl3sa2 driver with same parameters as the one when "PNP OS=YES", and it worked. 

After few more test I come to conclusion that when "dma=0" is used the sound card hangs at playback and with "dma2=0" it hangs at recording.

As dma0 is listed as valid channel in pnpdump output, I'd say it is not pnp fault for using it.
I do not exclude the possibility that it is hardware problem.

Note You need to log in before you can comment on or make changes to this bug.