Bug 3068 - linux 2.6.8-rc1 panics when compiling perl
linux 2.6.8-rc1 panics when compiling perl
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Product: Other
Classification: Unclassified
Component: Other
i386 Linux
: P2 high
Assigned To: other_other
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-14 17:19 UTC by marduk
Modified: 2004-07-19 19:10 UTC (History)
0 users

See Also:
Kernel Version: 2.6.8-rc1
Tree: Mainline
Regression: ---


Attachments

Description marduk 2004-07-14 17:19:46 UTC
Distribution: Gentoo
Hardware Environment: Athlon 2700+
Software Environment: gcc 3.3.3-r6, glibc 2.3.4.20040619
Problem Description: When compiling perl 5.8.4, kernel panics with no debuging
info other than:

Kernel panic: Aiee, killing interrupt handler!
In interrupt handler - Not syncing

I was not able to get any other debugging info, even with netconsole.  Anyway,
perl appears to build fine, but the kernel panics in the testing stage,
specifically after the "t/op/lfs" test, which says

# NOTE: this file tests how large files (>2GB) work with perlio (stdio/sfio).
# sysopen(), sysseek(), syswrite(), sysread() are tested in t/lib/syslfs.t.
# If you modify/add tests here, remember to update also ext/Fcntl/t/syslfs.t.

Please let me know if you need any further info.  I'd be happy to help however I
can.
Comment 1 Andrew Morton 2004-07-14 17:33:38 UTC
That sounds fairly serious.  

Please write down the oops trace from the screen, or
take a photograph of the screen.   We do need
that trace.

Thanks.
Comment 2 marduk 2004-07-14 17:48:07 UTC
Yes, I guess the problem is I don't get a trace, at least not the trace info
I've seen on previous panics.  I just get that two-line panic message.  It had
been suggested that I use a serial console or netconsole.  I used netconsole (I
don't have a serial device handy ATM) but only got the two-liner on the
netconsole as well.  Likewise there's nothing in syslog.

Perhaps there's some setting I can enable in there kernel config to get more
debugging info?
Comment 3 marduk 2004-07-19 19:10:36 UTC
Compiles and tests fine on rc2.  Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.