Bug 30142 - Kernel Oops after hibernation - lenovo t500
Kernel Oops after hibernation - lenovo t500
Status: CLOSED UNREPRODUCIBLE
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216 27352
  Show dependency treegraph
 
Reported: 2011-03-01 08:12 UTC by Willi Mann
Modified: 2011-03-30 20:48 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.38-rc6
Tree: Mainline
Regression: Yes


Attachments
dmesg log from the oops (4.80 KB, application/x-gzip)
2011-03-01 09:57 UTC, Willi Mann
Details

Description Willi Mann 2011-03-01 08:12:37 UTC
Afer Hibernation, I get attached kernel Oopses. This is with the current Debian Kernel from experimental.

I was able to login from another machine to access the dmesg log, but an attempt to reboot hangs. sync also hangs.
Comment 1 Willi Mann 2011-03-01 09:57:38 UTC
Created attachment 49732 [details]
dmesg log from the oops
Comment 2 Rafael J. Wysocki 2011-03-01 20:44:39 UTC
What exactly do you do to reproduce the problem?

BTW, please don't attach compressed logs.  It's _very_ inconvenient to review
them in this form and you don't really save any space that would matter this
way.
Comment 3 Willi Mann 2011-03-06 13:11:43 UTC
Sorry for the late answer, I missed the bugzilla notification somehow.

The Oops occured after a wakeup from suspend to disk, initiated over the KDE start menu, which calls pm-hibernate, which I configured to use in kernel suspend, with HIBERNATE_MODE="shutdown". It was probably not the first hiberation since the last cold boot. 

Some further information:

The notebook is a Lenovo T500, with Switchable Graphics (Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller + some ATI) but I'm only using the Intel graphic (set in BIOS).

Since the switch to kernel mode-setting, I had various problems with hibernation. At least since 2.6.36, the probability that the wakeup fails went down. However, after a few cycles (2 to 10) after a cold boot, I still end up with some error. Either it is an OOps as reported, or it is screen corruption or as seen a few days ago, filesystem corruption (only root fs (ext3) was affected and e2fsck could fix it + debsums didn't show any errors.)

I reported the Oops because it occured the second time with 2.6.37-rc6 when I decided it to report. Interestingly, since then I experienced the filesystem corruption, but I didn't see the Oops again. 

Another strange experience is that sometimes after a successful wakeup from hibernation, the system feels much slower than after a cold boot - not only a few minutes after the wakeup, really the whole session.) However, I don't know how to give this a metric and I'm not sure whether this is related - that problem might be related to the OnBoard Audio controller.
Comment 4 Len Brown 2011-03-22 01:47:01 UTC
can you reproduce this issue in 2.6.38?
what is the most recent kernel that did not have this problem?


can you reproduce with the acpi "video" driver excluded from the system?
Comment 5 Willi Mann 2011-03-28 11:35:06 UTC
So far, I can't reproduce this problem with 2.6.38. I'm using this kernel since a week without a cold reboot. Hopefully, I'm not just currently lucky and the problem is really gone.
Comment 6 Florian Mickler 2011-03-30 20:48:21 UTC
Alright, thanks for the update. I'm closing this as unreproducible. If it returns,
just post a note.

Note You need to log in before you can comment on or make changes to this bug.