Bug 30102 - [RADEON:KMS:RS780:CP] ring test failed
[RADEON:KMS:RS780:CP] ring test failed
Status: RESOLVED OBSOLETE
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
x86-64 Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-28 16:28 UTC by Mathieu Belanger
Modified: 2014-09-03 02:03 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.38-rc6
Tree: Mainline
Regression: No


Attachments
dmesg (59.17 KB, text/plain)
2011-02-28 16:28 UTC, Mathieu Belanger
Details
.config (71.97 KB, text/plain)
2011-02-28 16:31 UTC, Mathieu Belanger
Details

Description Mathieu Belanger 2011-02-28 16:28:25 UTC
Created attachment 49622 [details]
dmesg

On the radoen module load, I got this error:

[    9.874444] [drm:r600_ring_test] *ERROR* radeon: ring test failed (scratch(0x8504)=0xCAFEDEAD)
[    9.874447] radeon 0000:01:05.0: disabling GPU acceleration
[    9.875771] radeon 0000:01:05.0: ffff88043c78dc00 unpin not necessary

This is intermittent. I got theses error two weeks ago and it vanish after a reboot about 1 week ago. The video acceleration was working perfectly until yesterday reboot (adding an option in the kernel) and now the problem is back.

After the problem came back, I tried booting on the 3 others kernels I used this week (when it was working correctly) and the problem is still there with them.

I have attached the dmesg and my .config if this can help find the problem.
Comment 1 Mathieu Belanger 2011-02-28 16:31:29 UTC
Created attachment 49632 [details]
.config
Comment 2 Mathieu Belanger 2011-02-28 16:32:39 UTC
If you see the dmesg, you can see that this error is present on the two video card (I tested with the onboard one disabled, no change).
Comment 3 Mathieu Belanger 2011-02-28 16:32:57 UTC
00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge Alternate
00:01.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (int gfx)
00:02.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (ext gfx port 0)
00:09.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 4)
00:0a.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 5)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [AHCI mode]
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3c)
00:14.1 IDE interface: ATI Technologies Inc SB700/SB800 IDE Controller
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:14.5 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI2 Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Link Control
01:05.0 VGA compatible controller: ATI Technologies Inc RS880 [Radeon HD 4200]
01:05.1 Audio device: ATI Technologies Inc RS880 Audio Device [Radeon HD 4200]
02:00.0 VGA compatible controller: ATI Technologies Inc RV770 [Radeon HD 4870]
02:00.1 Audio device: ATI Technologies Inc HD48x0 audio
03:00.0 Network controller: RaLink RT2860
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
05:06.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 0a)
05:06.1 Input device controller: Creative Labs SB Live! Game Port (rev 0a)
Comment 4 Alan 2012-08-17 10:58:28 UTC
If this is still seen with a modern kernel (3.2+ etc) please update/re-open
Comment 5 maolihappy 2013-01-19 05:51:34 UTC
I have this problem either.my kernel version is 3.0.34.
can anyone help?
thanks a lot.
Comment 6 Alex Deucher 2013-01-19 15:57:11 UTC
Is this still an issue with a modern kernel?
Comment 7 maolihappy 2013-01-20 08:09:26 UTC
 I don't know either. However, I have this question. My version of kernel is 3.0.34 and on the Internet I find that kernel 3.1 may solve this problem. Who can tell me that what is the initial version could solve this problem ?
Comment 8 Alex Deucher 2013-01-20 14:40:26 UTC
I've never been able to reproduce this problem on any RS780 hardware that I have access to.  3.0.34 is really old.  There have been a lot of changes in the driver since then that could have fixed it.
Comment 9 maolihappy 2013-01-21 03:04:59 UTC
 My hardware is rv770, and I try to avoid the ring_test. However, the dmesg shows error on ib_test ad return to 0xCAFEDEAD. Could you tell me the reason of this problem? Is the problem raised coz of my config?
Thanks and regads.
Comment 10 Alex Deucher 2013-01-21 21:06:07 UTC
Are you still seeing this with a newer kernel?  3.0.34 is really old.
Comment 11 Alex Perez 2014-09-02 21:16:35 UTC
Multiple users including myself are experiencing this problem on PPC64 (big-endian) with kernel 3.8.13.
Comment 12 Michel Dänzer 2014-09-03 02:03:05 UTC
(In reply to Alex Perez from comment #11)
> Multiple users including myself are experiencing this problem on PPC64
> (big-endian) with kernel 3.8.13.

The symptoms may be similar or even the same, but it's unlikely to be the same problem. Please file your own report, preferably at

https://bugs.freedesktop.org/enter_bug.cgi?product=DRI

but here is fine as well.

Note You need to log in before you can comment on or make changes to this bug.