Bug 30032 - r8169: 60 seconds delay when resuming from suspend
r8169: 60 seconds delay when resuming from suspend
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 low
Assigned To: Francois Romieu
:
: 29912 (view as bug list)
Depends on:
Blocks: 7216 27352
  Show dependency treegraph
 
Reported: 2011-02-27 16:52 UTC by Guillaume Ayoub
Modified: 2011-03-27 19:52 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.38-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Guillaume Ayoub 2011-02-27 16:52:46 UTC
As explained in f1e02ed109df5f99abf942b8ccc99960cb09dd38, a 60 seconds delay happens when resuming from suspend, freezing the system. After this delay, everything is OK.

2 workarounds:
- Install the realtek firmware, or
- Unload the r8169 module before suspending.

This delay was not happening with 2.6.37 (the firmware was included in the kernel). For the record, the firmware was removed from the kernel in bca03d5f32c8ee9b5cfa1d32640a63fded6cb3c0.

I'm ready to debug or test patches if needed.
Comment 1 Mehmet Giritli 2011-03-06 14:13:55 UTC
I am having the same problem. Can you please tell me where I can get the firmware for realtek chips?
Comment 2 Guillaume Ayoub 2011-03-06 15:18:25 UTC
AFAIK, the easiest way to get the Realtek firmware is to take it from the Debian package:
http://packages.debian.org/fr/sid/firmware-realtek
Comment 3 Mehmet Giritli 2011-03-06 16:21:20 UTC
(In reply to comment #2)
> AFAIK, the easiest way to get the Realtek firmware is to take it from the
> Debian package:
> http://packages.debian.org/fr/sid/firmware-realtek

Thanks man, I got the firmware and the problem is now gone.
Comment 4 Mehmet Giritli 2011-03-06 16:22:14 UTC
*** Bug 29912 has been marked as a duplicate of this bug. ***
Comment 5 Rafael J. Wysocki 2011-03-27 19:51:43 UTC
Partially fixed by commit f1e02ed109df5f99abf942b8ccc99960cb09dd38 .

Note You need to log in before you can comment on or make changes to this bug.