Bug 29802 - [REGRESSION 2.6.38-rc1+] bisected to: USB: use the no_callbacks flag for interfaces
[REGRESSION 2.6.38-rc1+] bisected to: USB: use the no_callbacks flag for inte...
Status: CLOSED INVALID
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 7216 27352
  Show dependency treegraph
 
Reported: 2011-02-24 05:43 UTC by bettiah
Modified: 2011-03-06 12:00 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.38-rc6
Tree: Mainline
Regression: Yes


Attachments

Description bettiah 2011-02-24 05:43:39 UTC
On an embedded system, (beagleboard using Asix CONFIG_USB_NET_AX8817X statically compiled,  usb/ethernet bridge, rootfs over nfs),  : 

[    6.817382] usb 1-2.4: new high speed USB device using ehci-omap and address 3
[    6.940979] usb 1-2.4: rpm_resume flags 0x0
[    6.945373] usb 1-2.4: rpm_resume returns 1
[    6.961700] usb 1-2.4: New USB device found, idVendor=0b95, idProduct=772a
[    6.968963] usb 1-2.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    6.976684] usb 1-2.4: Product: AX88772 
[    6.980834] usb 1-2.4: Manufacturer: ASIX Elec. Corp.
[    6.986145] usb 1-2.4: SerialNumber: 000065
[    6.996917] usb 1-2.4: rpm_resume flags 0x4
[    7.001312] usb 1-2.4: rpm_resume returns 1
[    7.007507] usb 1-2.4: rpm_resume flags 0x4
[    7.011901] usb 1-2.4: rpm_resume returns 1
[    7.040679] mmc0: new SD card at address 9ffc
[    7.049255] mmcblk0: mmc0:9ffc SD01G 968 MiB 
[    7.061950]  mmcblk0: p1 p2
[    7.259307] usb usb2: rpm_suspend flags 0x9
[    7.263732] usb usb2: rpm_suspend returns 0
[    7.268310] usb usb2: rpm_suspend flags 0xa
[    7.272735] usb usb2: rpm_suspend returns 0
[    7.945953] asix 1-2.4:1.0: eth0: register 'asix' at usb-ehci-omap.0-2.4, ASIX AX88772 USB 
2.0 Ethernet, 00:00:00:00:00:65                                                              
[    7.957794] asix 1-2.4:1.0: rpm_suspend flags 0x4
[    7.962738] asix 1-2.4:1.0: rpm_suspend returns 0
[    7.967956] hub 1-2:1.0: rpm_resume flags 0x4
[    7.972534] hub 1-2:1.0: rpm_resume returns 1
[    7.977386] hub 1-2:1.0: rpm_suspend flags 0x4
[    7.982055] hub 1-2:1.0: rpm_suspend returns 0
[    8.333007] asix 1-2.4:1.0: rpm_resume flags 0x4
[    8.337890] asix 1-2.4:1.0: rpm_resume returns 0
[    8.343933] eth0: link down
[    9.368652] Sending DHCP requests .
[    9.949462] asix 1-2.4:1.0: rpm_resume flags 0x4
[    9.954498] asix 1-2.4:1.0: rpm_resume returns 1
[    9.961425] eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[   12.134307] .
[   12.135864] asix 1-2.4:1.0: rpm_resume flags 0x5
[   12.140869] asix 1-2.4:1.0: rpm_resume returns 1
[   12.649963] ,
[   12.651489] asix 1-2.4:1.0: rpm_resume flags 0x5
[   12.656524] asix 1-2.4:1.0: rpm_resume returns 1
[   12.665618]  OK
[   12.667480] IP-Config: Got DHCP answer from 0.0.0.0, my address is 192.168.1.102
[   12.678771] IP-Config: Complete:
[   12.682250]      device=eth0, addr=192.168.1.102, mask=255.255.255.0, gw=192.168.1.1,
[   12.690246]      host=192.168.1.102, domain=, nis-domain=(none),
[   12.696533]      bootserver=0.0.0.0, rootserver=192.168.1.106, rootpath=, mtu=576
[   12.715637] asix 1-2.4:1.0: rpm_resume flags 0x5
[   12.720489] asix 1-2.4:1.0: rpm_resume returns 1
[   12.725830] asix 1-2.4:1.0: rpm_resume flags 0x5
[   12.730651] asix 1-2.4:1.0: rpm_resume returns 1
[   12.742034] asix 1-2.4:1.0: rpm_resume flags 0x5
[   12.746887] asix 1-2.4:1.0: rpm_resume returns 1
[   12.752075] asix 1-2.4:1.0: rpm_resume flags 0x5
[   12.756927] asix 1-2.4:1.0: rpm_resume returns 1
:
:
(the last 2 lines keep repeating)

The system continues to work, the messages seem to be associated with activity on the network. But it slows down the system to the point of being unusable. 

This is a regression introduced in 2.6.37-rc1 and was bisected to : 

commit 63defa73c8c1193c1273474440c30d34c2524597
Author: Ming Lei <tom.leiming@gmail.com>
Date:   Mon Nov 15 15:56:54 2010 -0500

    USB: use the no_callbacks flag for interfaces
    
    Call pm_runtime_no_callbacks to set no_callbacks flag for USB
    interfaces.  Since interfaces cannot be power-managed separately from
    their parent devices, there's no reason for the runtime-PM core to
    invoke any callbacks for them.
    
    Signed-off-by: Ming Lei <tom.leiming@gmail.com>
    Reviewed-by: Alan Stern <stern@rowland.harvard.edu>
    Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>

BR
Abhishek
Comment 1 Alan Stern 2011-02-24 15:03:06 UTC
As  Ming Lei pointed out, this is neither a regression nor a bug.  If all these debugging messages are slowing down the system, you should turn off debugging by disabling CONFIG_DEBUG_DRIVER and CONFIG_PM_VERBOSE.
Comment 2 bettiah 2011-02-25 01:38:50 UTC
You two are right, I will have to look elsewhere for the problem I am seeing on 2.6.38rcs. I will close the bug.

Thanks.
Abhishek

Note You need to log in before you can comment on or make changes to this bug.