Bug 29782 - toshiba_acpi, issues with high temperature (fan does not cool), etc. Laptop: Toshiba Satellite Pro U500
toshiba_acpi, issues with high temperature (fan does not cool), etc. Laptop: ...
Status: RESOLVED OBSOLETE
Product: Drivers
Classification: Unclassified
Component: Platform
x86-64 Linux
: P1 normal
Assigned To: acpi_power-thermal
:
: toshiba (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-23 23:21 UTC by jadd
Modified: 2012-08-16 11:08 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.36.2
Tree: Mainline
Regression: No


Attachments
ACPI Table (TAR - uncompressed) (80.00 KB, application/x-tar)
2011-02-23 23:21 UTC, jadd
Details
dmesg Mandriva (bzip2) (12.49 KB, application/x-bzip2)
2011-02-23 23:23 UTC, jadd
Details
dmesg Sabayon (bzip2) (9.17 KB, application/x-bzip2)
2011-02-23 23:24 UTC, jadd
Details
lsmod Mandriva (7.89 KB, text/plain)
2011-02-23 23:26 UTC, jadd
Details
other outputs Mandriva 2010.2 (5.89 KB, text/plain)
2011-02-23 23:28 UTC, jadd
Details
config Mandriva (bzip2) (26.70 KB, application/x-bzip2)
2011-02-24 02:19 UTC, jadd
Details

Description jadd 2011-02-23 23:21:16 UTC
Created attachment 48782 [details]
ACPI Table (TAR - uncompressed)

Laptop: Toshiba Satellite Pro U500
Is mpossible loaded toshiba_acpi.ko, issues with high temperature (fan does not cool), with backlight and with some hotkeys Fn.

All attachments except the output of "dmesg" from Sabayon, are performed in the Mandriva 2010.2

modprobe --show-depends toshiba_acpi
insmod /lib/modules/2.6.36.2-desktop-2mnb/kernel/drivers/leds/led-class.ko.gz 
insmod /lib/modules/2.6.36.2-desktop-2mnb/kernel/net/rfkill/rfkill.ko.gz 
insmod /lib/modules/2.6.36.2-desktop-2mnb/kernel/drivers/platform/x86/toshiba_acpi.ko.gz

modprobe toshiba_acpi
FATAL: Error inserting toshiba_acpi (/lib/modules/2.6.36.2-desktop-2mnb/kernel/drivers/platform/x86/toshiba_acpi.ko.gz: No such device

Atachments 1. ACPI Table
           2. dmesg (Mandriva)
           3. dmesg (Sabayon)
           4. lsmod (Mandriva)
           5. other outputs
Comment 1 jadd 2011-02-23 23:23:44 UTC
Created attachment 48792 [details]
dmesg Mandriva (bzip2)
Comment 2 jadd 2011-02-23 23:24:41 UTC
Created attachment 48802 [details]
dmesg Sabayon (bzip2)
Comment 3 jadd 2011-02-23 23:26:48 UTC
Created attachment 48812 [details]
lsmod Mandriva
Comment 4 jadd 2011-02-23 23:28:41 UTC
Created attachment 48822 [details]
other outputs Mandriva 2010.2
Comment 5 jadd 2011-02-24 02:19:30 UTC
Created attachment 48832 [details]
config Mandriva (bzip2)
Comment 6 Alan 2012-08-16 11:07:11 UTC
If this is still seen with a modern kernel (3.2 etc) please update/re-open thanks
Comment 7 Alan 2012-08-16 11:08:13 UTC
*** Bug 29872 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.