Bug 2969 - S3 resume: IDE fails - Sony Vaio PCG-FXA49
S3 resume: IDE fails - Sony Vaio PCG-FXA49
Status: REJECTED DUPLICATE of bug 2039
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
i386 Linux
: P2 normal
Assigned To: Shaohua
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-27 13:34 UTC by Nathan Conrad
Modified: 2005-12-22 20:46 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.7-rc2
Tree: Mainline
Regression: ---


Attachments

Description Nathan Conrad 2004-06-27 13:34:02 UTC
Distribution: Debian Sid
Hardware Environment: Sony Vaio PCG-FXA49 (1.2 GHz Athlon4 with Via chipset)
Problem Description: Entering S3 sleep seems to work. The laptop powers down,
etc.... The laptop also wakes up correctly after I press the power button. I am
able to switch terminals, move the X cursor around, etc.... But, any process
trying to access the hard drive fails (and hangs). The hard drive light turns on
during the attempted disk access, but never turns off. The magic sysrq keys are
able to shut down the machine.

Steps to reproduce:
echo 3 > /proc/acpi/sleep
[press power button]
ls /some/directory/not/in/cache
[Hard drive light turns on, and ls hangs]

Info on my ATA controller:
0000:00:07.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
Comment 1 Shaohua 2004-06-29 18:57:15 UTC
Please try the latest patch in bug 2643. Thanks.
Comment 2 Nathan Conrad 2004-06-30 00:24:43 UTC
I just compiled 2.6.7 with the latest patch, and the symptoms are the same. The
patch does not help.
Comment 3 Len Brown 2004-11-03 23:25:39 UTC
any change with linux-2.6.9?
Comment 4 Nathan Conrad 2004-11-04 07:15:13 UTC
I just tried the stock Debian 2.6.9-1-k7 kernel. The same thing happened,
although the video did not seem to resume, probably since I was using the
console graphics. Before, I was using the VESA graphics driver.
Comment 5 Juha J 2004-12-07 05:46:59 UTC
I get the same symptoms on two different systems, the other with Promise
PDC20265 and the other with VT82Cxxxx/VT823xxx. Kernels 2.6.[589], all my own
configurations. For a more thorough report, including many complaints in syslog,
see http://lists.debian.org/debian-user/2004/11/msg03828.html.

By the way, fiddling around with IRQ's (making sure PDC got its private IRQ) did
not help. Also, doing hdparm -d 0 /dev/hda before going to suspend does not help
(so I dare say it is not a DMA problem).
Comment 6 Shaohua 2005-08-25 00:08:16 UTC
Could we have an update with latest kernel?
Comment 7 Shaohua 2005-11-08 19:54:49 UTC
Could you please try the patch at bug 2039 and report it back? Let's see if 
the IDE failure is caused by lack of invoking ACPI metthods.
Comment 8 Shaohua 2005-12-22 20:46:52 UTC

*** This bug has been marked as a duplicate of 2039 ***

Note You need to log in before you can comment on or make changes to this bug.