Bug 2962 - how to make ns558 oops
how to make ns558 oops
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Input Devices
i386 Linux
: P2 normal
Assigned To: Adam Belay
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-27 01:33 UTC by CASTET Matthieu
Modified: 2005-12-20 14:33 UTC (History)
0 users

See Also:
Kernel Version: 2.6.7
Tree: Mainline
Regression: ---


Attachments
syslog when ns558 Oops (3.41 KB, text/plain)
2004-06-27 01:34 UTC, CASTET Matthieu
Details
gameport-fix (685 bytes, patch)
2004-06-28 07:56 UTC, Adam Belay
Details | Diff

Description CASTET Matthieu 2004-06-27 01:33:20 UTC
hello,
here the way to make ns558 oops :

have snd-intel8x0 loaded whith joystick enable.

load ns558, there is a error message : 
"pnp: Unable to assign resources to device 00:17.
ns558: probe of 00:17 failed with error -16"

if you try to reload ns558, you have a error -17.

then if you unload snd-intel8x0, and you try to load ns558, you have a oops (see
atachement).

matthieu CASTET
Comment 1 CASTET Matthieu 2004-06-27 01:34:44 UTC
Created attachment 3254 [details]
syslog when ns558 Oops
Comment 2 Adam Belay 2004-06-28 07:56:48 UTC
Created attachment 3267 [details]
gameport-fix

Could you try this patch?
Comment 3 CASTET Matthieu 2004-06-29 00:22:17 UTC
Ok, now ns558 don't oops, but it load event if it detect nothing (never return
ENODEV)...
Comment 4 CASTET Matthieu 2004-11-25 09:45:51 UTC
so why nothing like that is commit in the current kernel ?
Comment 5 Dmitry Torokhov 2005-12-20 14:01:56 UTC
It looks like the fix is in the mainline. Can we please close this bug?

Note You need to log in before you can comment on or make changes to this bug.