Bug 29532 (RTL8191SE) - Kernel module for wireless PCI card Realtek RTL8191SE/RTL8192SE
Summary: Kernel module for wireless PCI card Realtek RTL8191SE/RTL8192SE
Status: RESOLVED CODE_FIX
Alias: RTL8191SE
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: All Linux
: P1 blocking
Assignee: Larry Finger
URL: http://www.realtek.com/products/produ...
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-20 17:33 UTC by Mathieu Malaterre
Modified: 2011-06-19 02:31 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.37
Tree: Mainline
Regression: No


Attachments

Description Mathieu Malaterre 2011-02-20 17:33:45 UTC
I did not manage to use my PCI wireless card RTL8191SE with linux 2.6.37.

It seems like drivers/staging/rtl8192e/r8192E_core.c is missing implementation for my hardware:


$ lspci -s 07:00.0 -n
07:00.0 0280: 10ec:8172 (rev 10)


$ lspci -s 07:00.0 -vvx
07:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8191SEvB Wireless LAN Controller (rev 10)
	Subsystem: Realtek Semiconductor Co., Ltd. Device 8181
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 17
	Region 0: I/O ports at 2000 [size=256]
	Region 1: Memory at d1100000 (32-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: rtl819xSE
00: ec 10 72 81 07 00 10 00 10 00 80 02 00 00 00 00
10: 01 20 00 00 00 00 10 d1 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 ec 10 81 81
30: 00 00 00 00 40 00 00 00 00 00 00 00 0b 01 00 00


Reference:
http://www.realtek.com/products/productsView.aspx?Langid=1&PNid=21&PFid=48&Level=5&Conn=4&ProdID=226
Comment 1 Mathieu Malaterre 2011-02-21 16:14:56 UTC
On Mon, Feb 21, 2011 at 5:06 PM, Larry Finger <Larry.Finger lwfinger ! net> wrote:
> As part of our collaborative effort, Realtek has sent me a mac80211-based
> driver for the RTL8192SE. It will be submitted to the wireless mailing list
> for review once the driver for the RTL8192CU is accepted. The earliest this
> would happen is 2.6.39, but I think 2.6.40 is more realistic. I also have a
> driver for the RTL8192DE that will follow the RTL8192SE.
Comment 2 Mathieu Malaterre 2011-06-16 19:01:24 UTC
Looks like 3.0.0 will contains a driver for RTL8191SE
Comment 3 Larry Finger 2011-06-19 02:30:47 UTC
Yes. That driver is in 3.0.

Note You need to log in before you can comment on or make changes to this bug.