Bug 2934 - ACPI0006 - GPE block device support
ACPI0006 - GPE block device support
Status: CLOSED WILL_NOT_FIX
Product: ACPI
Classification: Unclassified
Component: Config-Interrupts
i386 Linux
: P2 normal
Assigned To: Lan Tianyu
:
: 3249 (view as bug list)
Depends on: 3249
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-22 09:37 UTC by Len Brown
Modified: 2011-08-01 03:56 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.7
Tree: Mainline
Regression: No


Attachments
gpe block device driver (10.72 KB, patch)
2005-08-10 07:32 UTC, Luming Yu
Details | Diff
GPE block device driver (11.68 KB, patch)
2007-03-12 20:54 UTC, Zhang Rui
Details | Diff

Description Len Brown 2004-06-22 09:37:24 UTC
ACPI 2.0 specifies the ACPI0006 GPE block device,
which is used to handle General Purpose Events
above and beyond those specified in the FADT.

While high volume systems do not use ACPI0006,
large systesm on the horizon will need support
for this device.
Comment 1 Robert Moore 2004-06-30 10:38:58 UTC
The basic support for GPE block devices already exists in the ACPI CA code; 
what is required is a device driver that is loaded when ACPI0006 is detected.  
This driver will call the ACPI CA core and install the GPE block.
Bob
Comment 2 Len Brown 2004-11-14 20:54:06 UTC
from Matthew Wilcox: 
http://marc.theaimsgroup.com/?l=acpi4linux&m=109983990305150&w=4 
Comment 3 Luming Yu 2004-12-06 06:13:24 UTC
*** Bug 3249 has been marked as a duplicate of this bug. ***
Comment 4 Luming Yu 2005-08-10 07:32:28 UTC
Created attachment 5581 [details]
gpe block device driver

Original author: matthew@wil.cx
Incremental patch: luming.yu@intel.com
Comment 5 Len Brown 2007-03-08 21:02:07 UTC
we've let this one bit rot long enough that it doesn't apply -- re-opening.
Comment 6 Zhang Rui 2007-03-12 20:54:34 UTC
Created attachment 10737 [details]
GPE block device driver

I don't know why CONFIG_ACPI_GPE_BLOCK depends on !IA64_SGI_SN2, as shown in
the original patch.
And I think it should be put into the -mm tree for some test.
Comment 7 Fu Michael 2007-09-19 01:02:55 UTC
Rui to refresh the patch and submit to Len for review. Do we need machine to test before apply?
Comment 8 Len Brown 2007-09-20 19:58:48 UTC
Matt mentioned that he should be able to take this to closure --
assigning it (back) to him.
Comment 9 Natalie Protasevich 2008-03-03 21:13:47 UTC
Any updates on this? It looks like the patch hasn't been committed yet.
Comment 10 Len Brown 2008-03-25 19:26:30 UTC
Documenting that Linux does not support GPE block devices.
closed.
Comment 11 Len Brown 2011-02-23 00:26:48 UTC
re-opening, looks like we'll have a customer for this driver after-all...
Comment 12 Len Brown 2011-08-01 03:56:28 UTC
never mind, the customer for this driver again vanished...

Note You need to log in before you can comment on or make changes to this bug.