Bug 29042 - Cannot set sens with iwconfig for ath5k
Cannot set sens with iwconfig for ath5k
Status: CLOSED DUPLICATE of bug 28972
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 normal
Assigned To: drivers_network-wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-13 15:59 UTC by Mike Cloaked
Modified: 2011-02-14 15:54 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.35.11-83.fc14.i686.PAE
Tree: Mainline
Regression: No


Attachments

Description Mike Cloaked 2011-02-13 15:59:07 UTC
Am using a netbook with 
02:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)

The ath5k driver is loaded:
lsmod|grep ath
ath5k                 143403  0
mac80211              188716  1 ath5k
ath                     7145  1 ath5k
cfg80211              110951  3 ath5k,mac80211,ath

If I try to change the sensitivity value it is refused because the driver
does not support this parameter:
iwconfig wlan0 sens -65
yields:
Error for wireless request "Set Sensitivity" (8B08) :
     SET failed on device wlan0 ; Operation not supported.

Is there any patch being considered to allow support for the sens parameter?
This is needed for wireless roaming to work properly, as well as for correct
initial selection of a near AP with the same ssid as a previously connected
one, but which is now a weak signal at NetworkManager startup.
Comment 1 John W. Linville 2011-02-14 15:53:36 UTC

*** This bug has been marked as a duplicate of bug 28972 ***

Note You need to log in before you can comment on or make changes to this bug.