Bug 28982 - Dell latitude E6510 fails to resume from S3
Dell latitude E6510 fails to resume from S3
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 high
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 7216 27352
  Show dependency treegraph
 
Reported: 2011-02-12 23:25 UTC by devsk
Modified: 2011-02-21 21:10 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.38-rc4-git4
Tree: Mainline
Regression: Yes


Attachments

Description devsk 2011-02-12 23:25:15 UTC
Dell Latitude E6510 suspends to memory fine but on resume the screen stays black and everything is non-responsive. This happens with 2.6.38-rc4 and beyond. 2.6.38-rc3 resumed fine from suspend to S3. (My current stable release on this machine is 2.6.36 which suspends and resumes fine, with uptimes of many weeks).

The symptoms are:

1. The screen is blank.
2. caps lock doesn't light up the caps LED.
3. ACPID based shutdown doesn't trigger when I press the shutdown button.
4. The wifi connection doesn't come up.
5. The sysrq doesn't work.
6. Only thing works is long press on the power.

The things I have tried:

1. Got rid of DRM/i915 completely (all modules blacklisted). The system resumes fine (all the above things work) but the display is still blank. wifi works and I can login and troubleshoot. But no matter what I tried, I could not get the display to wake up.

2. Tried acpi_sleep=nonvs. Same behavior.

3. Tried pm-suspend from the console instead of within X. Same behavior: hard lock up with DRM/i915 and blank display without it.

4.  'vbetool post' after the resume segfaults.

Does this have anything to do with recent NX changes? vbetool post never segfaulted before.
Comment 1 devsk 2011-02-13 00:10:51 UTC
Applied the following and the resume from S3 works fine now.

0001-drm-i915-Fix-resume-regression-from-5d1d0cc.patch
1-1-Probe-for-output-switch-method-when-searching-video-devices..patch
Comment 2 Andrew Morton 2011-02-14 23:36:10 UTC
Where did you get those patches from?
Comment 3 Rafael J. Wysocki 2011-02-14 23:40:28 UTC
One if from the Intel DRM tree and the other is from the ACPI tree, both
are going to be pushed to Linus in foreseeable future.
Comment 4 devsk 2011-02-15 00:01:07 UTC
(In reply to comment #2)
> Where did you get those patches from?

These were found from the excellent buglist maintained by Rafael in the tracker bug! Great job there Rafael!

I probably would have looked at that bug first if I knew about it. Now, I have it bookmarked...:-)
Comment 5 Rafael J. Wysocki 2011-02-21 21:10:36 UTC
Fixed by commits:
04dbff5 drm/i915: Fix resume regression from 5d1d0cc
ed764e7 ACPI / Video: Probe for output switch method when searching video devices.

Note You need to log in before you can comment on or make changes to this bug.