Bug 28942 - no more brightness control on Fujitsu-Siemens SI 2636 laptop with 2.6.38-RC4 kernel
no more brightness control on Fujitsu-Siemens SI 2636 laptop with 2.6.38-RC4 ...
Status: CLOSED DUPLICATE of bug 27702
Product: ACPI
Classification: Unclassified
Component: Power-Video
All Linux
: P1 normal
Assigned To: acpi_power-video
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-12 14:40 UTC by Tasev Nikola
Modified: 2011-04-26 02:24 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.38-RC4
Tree: Mainline
Regression: Yes


Attachments
dmidecode Fujitsu-Siemens SI2636 (10.30 KB, text/plain)
2011-02-12 14:40 UTC, Tasev Nikola
Details
dmesg 2.6.38-rc4 (48.58 KB, text/plain)
2011-02-12 14:47 UTC, Tasev Nikola
Details
lspci -vvv (26.13 KB, text/plain)
2011-02-12 14:48 UTC, Tasev Nikola
Details
scripts/ver_linux (1.11 KB, text/plain)
2011-02-12 14:49 UTC, Tasev Nikola
Details
Fujitsu-Siemens SI2636 dsdt.dsl (210.96 KB, text/x-dsl)
2011-02-12 14:52 UTC, Tasev Nikola
Details

Description Tasev Nikola 2011-02-12 14:40:40 UTC
Created attachment 47512 [details]
dmidecode Fujitsu-Siemens SI2636

Hello devs,

First thank you for your great work on linux an make all this possible.

After compiling a 2.6.38-RC4 kernel i found that the brightness control 
off my laptop Fujitsu-Siemens SI 2636 don't work anymore.
The brightness control work with the fn+F8 an fn+F9 keys with all 
previous version off the kernel i tried from 2.6.24 to 2.6.37 .
My system is Kubuntu 10.04 LTS with the kernel mode-settings and the 
intel video driver.

In the dmesg output off the 2.6.37 kernel i found 2 related lines :

[Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness

[drm:intel_panel_get_max_backlight] *ERROR* fixme: max PWM is zero.

But even with those errors the brightness control work fine with the 
2.6.37 kernel.

When using the 2.6.38-RC4 kernel i found that the directory 
/sys/class/backlight is empty.

Attached is dmidecode.

If you need more info just tell me


Tasev Nikola
Comment 1 Tasev Nikola 2011-02-12 14:47:15 UTC
Created attachment 47522 [details]
dmesg 2.6.38-rc4
Comment 2 Tasev Nikola 2011-02-12 14:48:31 UTC
Created attachment 47532 [details]
lspci -vvv
Comment 3 Tasev Nikola 2011-02-12 14:49:42 UTC
Created attachment 47542 [details]
scripts/ver_linux
Comment 4 Tasev Nikola 2011-02-12 14:52:40 UTC
Created attachment 47552 [details]
Fujitsu-Siemens SI2636 dsdt.dsl
Comment 5 Rafael J. Wysocki 2011-02-14 23:43:29 UTC
Does the patch from bug #27702 help?
Comment 6 Tasev Nikola 2011-02-15 18:58:07 UTC
Yes !

The patch is perfect. The keys for brightness control works again.

Thank you.
Comment 7 Len Brown 2011-04-26 02:24:32 UTC
thanks for testing

*** This bug has been marked as a duplicate of bug 27702 ***

Note You need to log in before you can comment on or make changes to this bug.