Bug 28832 - [regression][2.6.38-rcX][net][iwlagn] WiFi signal after period of time tanks causing contant drops
[regression][2.6.38-rcX][net][iwlagn] WiFi signal after period of time tanks ...
Status: CLOSED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 normal
Assigned To: drivers_network-wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks: 27352
  Show dependency treegraph
 
Reported: 2011-02-10 20:06 UTC by Maciej Rutecki
Modified: 2011-02-21 19:30 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.38-rc
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-02-10 20:06:34 UTC
Subject    : [regression][2.6.38-rcX][net][iwlagn] WiFi signal after period of time tanks causing contant drops
Submitter  : Shawn Starr <shawn.starr@rogers.com>
Date       : 2011-02-07 3:54
Message-ID : 613373.34172.qm@smtp106.rog.mail.re2.yahoo.com
References : http://marc.info/?l=linux-kernel&m=129705125832718&w=2

This entry is being used for tracking a regression from 2.6.37. Please don't
close it until the problem is fixed in the mainline.
Comment 1 John W. Linville 2011-02-10 20:37:28 UTC
I was seeing similar behaviour in -rc3, but not in -rc4.  Please have the user try that?
Comment 2 Shawn Starr 2011-02-11 05:38:32 UTC
From:	Shawn Starr <shawn.starr@rogers.com>  (sh0n.net)

Date:	Thu Feb 10 22:15:29 2011
On Thursday, February 10, 2011 10:07:48 PM Shawn Starr wrote:
> On Thursday, February 10, 2011 07:16:24 AM wwguy wrote:
> > On Wed, 2011-02-09 at 23:15 -0800, Andrew Morton wrote:
> > > (cc linux-wireless)
> > > 
> > > On Sun, 06 Feb 2011 22:54 -0500 Shawn Starr <shawn.starr@rogers.com>
> 
> wrote:
> > > > Using a Intel Corporation PRO/Wireless 5100 AGN [Shiloh] card
> > > > after
> > > > rebooting and a period of of seveal hours signal begins to drop
> > > > to
> > > > low levels:
> > > > 
> > > > 
> > > > wlan0     IEEE 802.11abgn  ESSID:"XXXXXXXX"
> > > > 
> > > >           Mode:Managed  Frequency:2.462 GHz  Access
> > > >           Point:
> > > >           AA:BB:CC:DD:EE:FF Bit Rate=11 Mb/s
> > > >           Tx-Power=15 dBm
> > > >           Retry  long limit:7   RTS thr:off   Fragment
> > > >           thr:off
> > > >           Power Management:off
> > > >           Link Quality=12/70  Signal level=-98 dBm
> > > >           Rx invalid nwid:0  Rx invalid crypt:0  Rx
> > > >           invalid frag:0
> > > >           Tx excessive retries:0  Invalid misc:35  
> > > >           Missed
> > > >           beacon:0
> > > > 
> > > > ...
> > > > 
> > > >           Link Quality=12/70  Signal level=-98 dBm
> > > >           Rx invalid nwid:0  Rx invalid crypt:0  Rx
> > > >           invalid frag:0
> > > >           Tx excessive retries:0  Invalid misc:40  
> > > >           Missed
> > > >           beacon:0
> > > > 
> > > > I start seeing lots of Invalid misc errors and connection drops.
> > > > If
> > > > I reboot, then signal will be back to normal for a period of
> > > > time
> > > > again.
> > > > 
> > > > My official kernel is from Fedora rawhide
> > > > (2.6.38-0.rc3.git4.1.fc15.x86_64)
> > > > 
> > > > Anyone else notice poor link/signal levels?
> > > > 
> > > > .37 showed no such issues.
> > 
> > did not see anything special from the log, is any environment or
> > condition changed? what AP you are using?
> > 
> > Thanks
> > Wey
> 
> I'm using an Linksys WRT54G with tomato firmware for a number of years. The
> AP is in my house and very close. I will keep an eye on this. This all
> seemed to have started after we had a power outage. The AP is fine however
> and I haven't noticed this drop a 2 after.
> 
> If there was any environment changes they appear to have 'settled' down.
> 
> I will be going to 2.6.38-0.rc4.git0.1.fc15 right now and will do another
> long hour test by keeping the laptop on for a number of hours on the
> weekend.

To answer myself, https://bugzilla.kernel.org/show_bug.cgi?id=28832

Looks like this is behavour observed in -rc3 the same period I did the 
upgrade. I can discount the power outage 

> 
> Thanks,
> Shawn.
Comment 3 Rafael J. Wysocki 2011-02-19 11:50:13 UTC
On Saturday, February 19, 2011, Shawn Starr wrote:
> On Sunday, February 13, 2011 12:05:21 AM Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a summary report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.37.  Please verify if it still should be listed and let the
> > tracking team know (either way).
> > 
> > 
> 
> I've left laptop on for a day, not seeing this anymore. Please close bug 
> ticket (but I have another regression coming up in another thread for 
> something else :/)

Note You need to log in before you can comment on or make changes to this bug.