Bug 28802 - commit 5d1d0cc breaks resume from suspend on Thinkpad X201
commit 5d1d0cc breaks resume from suspend on Thinkpad X201
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
: 28822 (view as bug list)
Depends on:
Blocks: 7216 27352
  Show dependency treegraph
 
Reported: 2011-02-10 17:23 UTC by Björn Schließmann
Modified: 2011-04-20 06:08 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.38-rc
Tree: Mainline
Regression: Yes


Attachments
configuration used while bisecting (92.43 KB, application/octet-stream)
2011-02-10 17:23 UTC, Björn Schließmann
Details
Don't touch active during reset (1.67 KB, patch)
2011-02-10 17:42 UTC, Chris Wilson
Details | Diff

Description Björn Schließmann 2011-02-10 17:23:39 UTC
Created attachment 47162 [details]
configuration used while bisecting

Resuming from suspend works on my Thinkpad X201 until commit 5d1d0cc87fc0887921993ea0742932e0c8adeda0 (bisected). When trying to wake up from resume, the power LED turns on, also hard disk and fan; but the screen stays black (backlight off). Computer is frozen, Alt-Sysrq hacks don't work anymore. Using /sys/power/pm_trace, "hash matches" leads to my i915 graphics adapter after reboot. My .config is attached. Please advise how I can help.


N.B.: Because of a different bug (#27472) resuming doesn't work out of the box since v2.6.38-rc3 and beyond; the patch for this bug is merged *after* 5d1d0cc. Cherry-picking d344e38b2c151ca5e5e39f562017127e93912528 after every bisect step worked wonders.
Comment 1 Chris Wilson 2011-02-10 17:42:02 UTC
Created attachment 47172 [details]
Don't touch active during reset
Comment 2 Chris Wilson 2011-02-10 20:34:30 UTC
*** Bug 28822 has been marked as a duplicate of this bug. ***
Comment 3 Björn Schließmann 2011-02-10 21:00:08 UTC
Patch from #1 resolves the issue for me (applied upon v2.6.38-rc4).
Comment 4 Rafael J. Wysocki 2011-02-12 22:48:12 UTC
Patch : https://bugzilla.kernel.org/attachment.cgi?id=47172
Handled-By : Chris Wilson <chris@chris-wilson.co.uk>
Comment 5 Florian Mickler 2011-02-19 23:59:47 UTC
merged in .38-rc5:
commit 04dbff52600719017598f7439bf42e5a72e7de3b
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Thu Feb 10 17:38:35 2011 +0000

    drm/i915: Fix resume regression from 5d1d0cc
Comment 6 Takashi Iwai 2011-02-21 10:09:59 UTC
This caused a yet again regression on PineView.
Now the old PineView S4 bug is back by this revert!
Comment 7 Florian Mickler 2011-03-30 21:29:10 UTC
Should this be reopened?
Comment 8 Rafael J. Wysocki 2011-04-17 13:41:56 UTC
Ignore-Patch : https://bugzilla.kernel.org/attachment.cgi?id=47172
Comment 9 Björn Schließmann 2011-04-18 21:15:50 UTC
On my machine, 04dbff5 fixes the bug.
Comment 10 Florian Mickler 2011-04-20 06:06:41 UTC
Thanks for verifying. Since you are the original reporter I'm closing this bug. 

Takashi, if your issue persists please open a new bug, so that, at least, we have some illusion of forward progress.
Comment 11 Florian Mickler 2011-04-20 06:08:36 UTC
(sorry, if that sounded saracastic. )

Note You need to log in before you can comment on or make changes to this bug.