Bug 28772 - oops in nfs_revalidate_mapping
oops in nfs_revalidate_mapping
Status: RESOLVED OBSOLETE
Product: File System
Classification: Unclassified
Component: NFS
All Linux
: P1 normal
Assigned To: David Howells
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2011-02-10 13:59 UTC by Daniel Poelzleithner
Modified: 2012-07-02 13:43 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.37
Tree: Mainline
Regression: Yes


Attachments
netconsole log (93.13 KB, application/x-gzip)
2011-03-14 18:46 UTC, Daniel Poelzleithner
Details

Description Daniel Poelzleithner 2011-02-10 13:59:48 UTC
Since 2.6.37 i get more oopses that are nfs related. I have cachefiles enables with cachefilesd version 0.9-3ubuntu1.

traceback:

Feb 10 14:31:14 cruor kernel: [153051.149861] PGD 1250a1067 PUD 113e01067 PMD 0 
Feb 10 14:31:14 cruor kernel: [153051.149861] CPU 0 
Feb 10 14:31:14 cruor kernel: [153051.149861] Modules linked in: nls_cp437 cifs binfmt_misc ip6table_filter ip6_tables ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat nf
_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack ipt_REJECT xt_tcpudp iptable_filter ip_tables x_tables kvm_amd kvm autofs4 sha256_generic cryptd aes_x86_64 aes_generic dm_
crypt rpcsec_gss_krb5 nfsd exportfs nfs snd_hda_codec_hdmi snd_emu10k1_synth snd_emux_synth snd_seq_virmidi snd_seq_midi_emul snd_hda_codec_realtek snd_emu10k1 snd_hda_intel sn
d_ac97_codec snd_hda_codec ac97_bus snd_pcm_oss snd_mixer_oss snd_pcm snd_util_mem snd_hwdep lockd nfs_acl snd_seq_dummy snd_seq_oss auth_rpcgss snd_seq_midi snd_rawmidi sunrpc
 snd_seq_midi_event snd_seq snd_timer bridge stp twofish_x86_64 twofish_common cachefiles fscache snd_seq_device ppdev it87 snd parport_pc hwmon_vid emu10k1_gp gameport joydev 
serio_raw k8temp firewire_sbp2 edac_core edac_mce_amd lp i2c_piix4 parport snd_page_alloc shpchp soundcore lzo btrfs zlib_deflate crc32c libcrc32c
Feb 10 14:31:14 cruor kernel: usb_storage uas usbhid hid fbcon tileblit font bitblit softcursor radeon firewire_ohci ttm firewire_core drm_kms_helper crc_itu_t pata_atiixp drm i2c_algo_bit [last unloaded: vboxdrv]
Feb 10 14:31:14 cruor kernel: [153051.149861] 
Feb 10 14:31:14 cruor kernel: [153051.149861] Pid: 3972, comm: krunner Not tainted 2.6.37 #4 GA-MA790X-DS4/GA-MA790X-DS4
Feb 10 14:31:14 cruor kernel: [153051.149861] RIP: 0010:[<ffffffffa01bd46a>]  [<ffffffffa01bd46a>] __fscache_read_or_alloc_pages+0x13a/0x2a0 [fscache]
Feb 10 14:31:14 cruor kernel: [153051.149861] RSP: 0018:ffff88010eac1a58  EFLAGS: 00010246
Feb 10 14:31:14 cruor kernel: [153051.149861] RAX: 0000000000000000 RBX: ffff880115a7be40 RCX: 00000000ffffffff
Feb 10 14:31:14 cruor kernel: [153051.149861] RDX: 0000000000000000 RSI: ffff88010eac19c8 RDI: ffff8800cfebf2d0
Feb 10 14:31:14 cruor kernel: [153051.149861] RBP: ffff88010eac1a98 R08: ffff88010eac0000 R09: 0000000000000000
Feb 10 14:31:14 cruor kernel: [153051.149861] R10: 0000000000000000 R11: 00000000ffffffff R12: ffff88010eac1c08
Feb 10 14:31:14 cruor kernel: [153051.149861] R13: ffff88010eac1b24 R14: ffff8801251ed200 R15: ffff88005817a6b0
Feb 10 14:31:14 cruor kernel: [153051.149861] FS:  00007fe12ac53780(0000) GS:ffff8800cfc00000(0000) knlGS:00000000f7708a90
Feb 10 14:31:14 cruor kernel: [153051.149861] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Feb 10 14:31:14 cruor kernel: [153051.149861] CR2: 0000000000000040 CR3: 000000010ea32000 CR4: 00000000000006f0
Feb 10 14:31:14 cruor kernel: [153051.149861] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Feb 10 14:31:14 cruor kernel: [153051.149861] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Feb 10 14:31:14 cruor kernel: [153051.149861] Process krunner (pid: 3972, threadinfo ffff88010eac0000, task ffff880123c72340)
Feb 10 14:31:14 cruor kernel: [153051.149861]  ffff88012fffbe00 ffff880118e855c0 ffffffffa0654d9a ffff88010eac1b24
Feb 10 14:31:14 cruor kernel: [153051.149861]  ffff88003d1909d0 ffff88003d190af8 00000000ffffff97 ffff88010eac1c08
Feb 10 14:31:14 cruor kernel: [153051.149861]  ffff88010eac1af8 ffffffffa067db8e 00000000000200da 0000000000000000
Feb 10 14:31:14 cruor kernel: [153051.149861]  [<ffffffffa0654d9a>] ? nfs_revalidate_mapping+0xba/0x140 [nfs]
Feb 10 14:31:14 cruor kernel: [153051.149861]  [<ffffffffa067db8e>] __nfs_readpages_from_fscache+0x7e/0x1b0 [nfs]
Feb 10 14:31:14 cruor kernel: [153051.149861]  [<ffffffffa065ea87>] nfs_readpages+0xd7/0x210 [nfs]
Feb 10 14:31:14 cruor kernel: [153051.149861]  [<ffffffff811327c9>] ? alloc_pages_current+0x99/0x100
Feb 10 14:31:14 cruor kernel: [153051.149861]  [<ffffffff810ff5a3>] __do_page_cache_readahead+0x133/0x210
Feb 10 14:31:14 cruor kernel: [153051.149861]  [<ffffffff810ff6a1>] ra_submit+0x21/0x30
Feb 10 14:31:14 cruor kernel: [153051.149861]  [<ffffffff810ffa55>] ondemand_readahead+0x115/0x240
Feb 10 14:31:14 cruor kernel: [153051.149861]  [<ffffffff81046c99>] ? __wake_up_common+0x59/0x90
Feb 10 14:31:14 cruor kernel: [153051.149861]  [<ffffffff810ffc81>] page_cache_sync_readahead+0x31/0x50
Feb 10 14:31:14 cruor kernel: [153051.149861]  [<ffffffff810f6c91>] generic_file_aio_read+0x551/0x6f0
Feb 10 14:31:14 cruor kernel: [153051.149861]  [<ffffffffa0651b09>] nfs_file_read+0xa9/0x110 [nfs]
Feb 10 14:31:14 cruor kernel: [153051.149861]  [<ffffffff8114705a>] do_sync_read+0xda/0x120
Feb 10 14:31:14 cruor kernel: [153051.149861]  [<ffffffff8125b6bb>] ? security_file_permission+0x8b/0x90
Feb 10 14:31:14 cruor kernel: [153051.149861]  [<ffffffff811473d5>] vfs_read+0xc5/0x190
Feb 10 14:31:14 cruor kernel: [153051.149861]  [<ffffffff81147b31>] sys_read+0x51/0x90
Feb 10 14:31:14 cruor kernel: [153051.149861]  [<ffffffff8100b002>] system_call_fastpath+0x16/0x1b
Feb 10 14:31:14 cruor kernel: [153051.149861]  RSP <ffff88010eac1a58>
Feb 10 14:31:14 cruor kernel: [153051.328784] ---[ end trace ebe4764bc6d66801 ]---
Comment 1 Trond Myklebust 2011-02-21 23:18:54 UTC
Reassigning to David Howells.
Comment 2 David Howells 2011-03-14 12:23:36 UTC
Hi Daniel,

It looks like you've not included a couple of lines before the start of the trace that you've pasted that say what the kernel's complaint actually is.

Could you have another look in your logs?

David
Comment 3 Daniel Poelzleithner 2011-03-14 18:46:22 UTC
Created attachment 50792 [details]
netconsole log

I only have the netconsole logs available. This shows some other cachefiles problems, too.
Comment 4 Florian Mickler 2011-03-29 21:17:07 UTC
Is this still a problem in 2.6.38.y?

Note You need to log in before you can comment on or make changes to this bug.