Bug 28762 - Hotkey[Fn+F5/F6] can't adjust brightness
Hotkey[Fn+F5/F6] can't adjust brightness
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: ACPI
Classification: Unclassified
Component: Power-Video
All Linux
: P1 normal
Assigned To: acpi_power-video
:
: 28752 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-10 10:04 UTC by reinhart
Modified: 2012-05-24 07:52 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.35.7
Tree: Mainline
Regression: No


Attachments
2.6.35.7 kernel configuration (68.98 KB, application/octet-stream)
2011-02-10 10:04 UTC, reinhart
Details

Description reinhart 2011-02-10 10:04:42 UTC
Created attachment 47102 [details]
2.6.35.7 kernel configuration

I encounter a problem that the brightness can't be adjusted when I press Fn+F5/F6 (brightness up/down) in Asus K52J machine.
I debug this problem when I change kernel command line options (acpi_backlight and acpi_display_output) from "vendor" to "video", and this problem is fixed.
I don't know whether the backlight device module (asus-laptop) causes this problem, but the same asus-laptop module don't occur this problem in Asus K42JR machine.
I hope that I can understand the reason of this problem.

Thank you for your help.

PS: In K52J machine : Fn+F5/F6 can work when enter BIOS setup window
PS2: In K42JR machine : Fn+F5/F6 can't work when enter BIOS setup window
Comment 1 reinhart 2011-02-10 10:21:57 UTC
May somebody tell me how to research kernel ACPI subsystem codes?
Thanks!!
Comment 2 Zhang Rui 2011-02-15 01:30:05 UTC
*** Bug 28752 has been marked as a duplicate of this bug. ***
Comment 3 Zhang Rui 2012-01-18 03:12:23 UTC
I suppose the bug still exists in the latest upstream kernel, right?
Please attach the acpidump output of this laptop.
Comment 4 Zhang Rui 2012-05-24 07:52:53 UTC
bug closed as there is no response from the bug reporter.
please feel free to reopen it if the problem still exists in the latest upstream kernel.

Note You need to log in before you can comment on or make changes to this bug.