Bug 2845 - ACPI_EC_UDELAY_COUNT too small
Summary: ACPI_EC_UDELAY_COUNT too small
Status: REJECTED DUPLICATE of bug 3851
Alias: None
Product: ACPI
Classification: Unclassified
Component: Other (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Luming Yu
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-06-06 13:22 UTC by Michael Graham
Modified: 2005-03-14 19:13 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.6
Tree: Mainline
Regression: ---


Attachments

Description Michael Graham 2004-06-06 13:22:40 UTC
Distribution: Debian Testing
Hardware Environment: Clevo D270S 
Problem Description: ACPI_EC_UDELAY_COUNT too small

On my laptop ACPI_EC_UDELAY_COUNT=10 is too small and I recieve time out errors
when loading the ec & battery modules. If I increase the number to 50 the
modules load correctly.

Would it be possible for this number to be increased in the kernel, by applying
the patch below or by adding a configure option to set the timeout value

Thanks,

OoberMick

diff -uNr kernel-source-2.6.6/drivers/acpi/ec.c
kernel-source-2.6.6.mick/drivers/acpi/ec.c
--- kernel-source-2.6.6/drivers/acpi/ec.c       2004-04-05 11:54:30.000000000 +0100
+++ kernel-source-2.6.6.mick/drivers/acpi/ec.c  2004-06-05 13:03:35.000000000 +0100
@@ -53,7 +53,7 @@
 #define ACPI_EC_EVENT_IBE      0x02    /* Input buffer empty */
 
 #define ACPI_EC_UDELAY         100     /* Poll @ 100us increments */
-#define ACPI_EC_UDELAY_COUNT   1000    /* Wait 10ms max. during EC ops */
+#define ACPI_EC_UDELAY_COUNT   5000    /* Wait 50ms max. during EC ops */
 #define ACPI_EC_UDELAY_GLK     1000    /* Wait 1ms max. to get global lock */
 
 #define ACPI_EC_COMMAND_READ   0x80
Comment 1 Len Brown 2004-11-03 22:54:58 UTC
i suppose we should time how long the delays
are actually turning out to be before we increase them --
there may be a problem with the delay function
rather than the delay value.

that said, i have no idea where the delay value comes from...
Comment 2 Luming Yu 2005-03-14 19:13:06 UTC
Burst mode EC won't have this issue. 
Closing it as duplicate with 3851.

*** This bug has been marked as a duplicate of 3851 ***

Note You need to log in before you can comment on or make changes to this bug.