Bug 28432 - khugepaged: gets stuck when writing to USB flash, 2.6.38-rc2
khugepaged: gets stuck when writing to USB flash, 2.6.38-rc2
Status: CLOSED DUPLICATE of bug 31142
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 27352
  Show dependency treegraph
 
Reported: 2011-02-06 20:01 UTC by Maciej Rutecki
Modified: 2011-03-27 19:55 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.38-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-02-06 20:01:53 UTC
Subject    : khugepaged: gets stuck when writing to USB flash, 2.6.38-rc2
Submitter  : Jindřich Makovička <makovick@gmail.com>
Date       : 2011-01-31 19:28
Message-ID : AANLkTi=uOpN0PwWdGh6iri-vJwuMS+WMPxmaZjv0-TrV@mail.gmail.com
References : http://marc.info/?l=linux-kernel&m=129650210516627&w=2

This entry is being used for tracking a regression from 2.6.37. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Chuck Ebbert 2011-03-27 01:12:20 UTC
The workaround found was:

echo never >/sys/kernel/mm/transparent_hugepage/defrag
echo no > /sys/kernel/mm/transparent_hugepage/khugepaged/defrag

I believe this problem is fixed in 2.6.39, and possibly in 2.6.38.2 as well (2.6.38.2 has commit d527caf22e48480b102c7c6ee5b9ba12170148f7, "mm: compaction: prevent kswapd compacting memory to reduce CPU usage".)
Comment 2 Jindrich Makovicka 2011-03-27 08:33:11 UTC
I'll give it a try, but I am not sure is this is the same problem. During the lockups I encountered, the CPU utilization was (almost) zero.
Comment 3 Chuck Ebbert 2011-03-27 18:02:01 UTC
Hmm, this appears to be a duplicate of bug 31142, which is being worked on actively. This bug should be closed as a duplicate of that one...
Comment 4 Rafael J. Wysocki 2011-03-27 19:55:20 UTC

*** This bug has been marked as a duplicate of bug 31142 ***

Note You need to log in before you can comment on or make changes to this bug.