Bug 28342 - suspend to RAM completely fails
suspend to RAM completely fails
Status: CLOSED DUPLICATE of bug 27472
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 high
Assigned To: power-management_other
:
Depends on:
Blocks: 7216 27352
  Show dependency treegraph
 
Reported: 2011-02-06 08:08 UTC by Werner Lemberg
Modified: 2011-02-12 22:26 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.38-rc3
Tree: Mainline
Regression: Yes


Attachments
boot.msg for 2.6.38-rc3 (73.61 KB, text/plain)
2011-02-06 08:08 UTC, Werner Lemberg
Details

Description Werner Lemberg 2011-02-06 08:08:51 UTC
Created attachment 46562 [details]
boot.msg for 2.6.38-rc3

[openSuSE kernel-pae 2.6.38-rc3.3.1]
[openSuSE pm-utils 1.4.1-1.2]

Starting with the 2.6.38 series, suspend to RAM completely fails.  It simply reboots.

This is a Dell Inspiron 6400 laptop.  Attached is my boot.msg.

Please tell me what further information you need for investigation.
Comment 1 Stephen Rothwell 2011-02-06 10:04:35 UTC
The boot log does not show any sign of APM.  A laptop this new would not use APM (it is an old legacy system) and is probably using ACPI.
Comment 2 Rafael J. Wysocki 2011-02-06 11:54:33 UTC
Does 2.6.37 work correctly?
Comment 3 Werner Lemberg 2011-02-06 16:59:39 UTC
To Stephen: Ah, yes, sorry for mixing it up.

To Rafael: Yes, with 2.6.37 suspend to RAM works just fine.
Comment 4 Rafael J. Wysocki 2011-02-06 18:44:02 UTC
Is the kernel 32-bit or 64-bit?
Comment 5 Werner Lemberg 2011-02-06 18:49:08 UTC
32bit (i586).
Comment 6 Rafael J. Wysocki 2011-02-06 19:00:18 UTC
In that case I think it's caused by commit 5bd5a45 (x86: Add NX protection for
kernel data).  It would be good to verify that, though.
Comment 7 Werner Lemberg 2011-02-07 05:37:38 UTC
Perhaps some kernel `command line option' could be temporarily added to switch this feature on or off...  Then I can test this easily as soon as it gets added to openSuSE's kernel repository.
Comment 8 Rafael J. Wysocki 2011-02-07 09:21:31 UTC
Unfortunately, that's just a kernel configuration option.  I could prepare a
test kernel for you, but I think it's better to wait until this (known) issue
is fixed.

I'll let you know when that happens.
Comment 9 Werner Lemberg 2011-02-07 09:32:18 UTC
Ah, it's a known problem.  I wasn't aware of this since I haven't found a bug report in bugzilla.  Thanks for your help.
Comment 10 Rafael J. Wysocki 2011-02-07 09:57:59 UTC
It's bug #27472 .  However, I'm still not sure you're seeing the same issue.

At this point it's better to wait until the fix for that bug is merged and
test a kernel containing it.
Comment 11 Werner Lemberg 2011-02-12 12:40:16 UTC
Using 2.6.38-rc4-6-pae, it works again.  Thanks for assistance.
Comment 12 Rafael J. Wysocki 2011-02-12 22:26:22 UTC
OK, closing.

*** This bug has been marked as a duplicate of bug 27472 ***

Note You need to log in before you can comment on or make changes to this bug.