Bug 28312 - wpa_supplicant does not recognize resume from suspend and does not reinicialize key
wpa_supplicant does not recognize resume from suspend and does not reiniciali...
Status: RESOLVED WILL_NOT_FIX
Product: Networking
Classification: Unclassified
Component: Wireless
All Linux
: P1 high
Assigned To: networking_wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2011-02-05 18:54 UTC by Cijoml Cijomlovic Cijomlov
Modified: 2013-12-11 13:50 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.12
Tree: Mainline
Regression: Yes


Attachments

Description Cijoml Cijomlovic Cijomlov 2011-02-05 18:54:25 UTC
After suspend/resume wpa_supplicant key is not reinicialized. Network stopped working.

My previous kernel 2.6.32.27 works no issues.

Eee:/home/cijoml# wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf  -i wlan0
CTRL-EVENT-SCAN-RESULTS
CTRL-EVENT-SCAN-RESULTS
Trying to associate with 00:1d:60:9d:a9:02 (SSID='CIJOML-2' freq=2472 MHz)
Associated with 00:1d:60:9d:a9:02
WPA: Key negotiation completed with 00:1d:60:9d:a9:02 [PTK=TKIP GTK=TKIP]
CTRL-EVENT-CONNECTED - Connection to 00:1d:60:9d:a9:02 completed (auth) [id=4 id_str=]
suspend/resume
no update

BEFORE suspend:
wlan0     Ralink STA  ESSID:"CIJOML-2"  Nickname:"RT2860STA"
          Mode:Managed  Frequency=2.472 GHz  Access Point: 00:1D:60:9D:A9:02
          Bit Rate=54 Mb/s
          RTS thr:off   Fragment thr:off
          Encryption key:DBF9-2D95-FCC5-85B0-37CB-6F15-1220-EC0D
          Link Quality=100/100  Signal level:-46 dBm  Noise level:-81 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


AFTER suspend:
wlan0     Ralink STA  ESSID:""  Nickname:"RT2860STA"
          Mode:Auto  Frequency=2.472 GHz  Access Point: 00:1D:60:9D:A9:02
          Bit Rate=1 Mb/s
          RTS thr:off   Fragment thr:off
          Encryption key:off
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
          Link Quality=100/100  Signal level:-44 dBm  Noise level:-97 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Comment 1 Rafael J. Wysocki 2011-02-05 23:00:32 UTC
What kernel version is the report against?
Comment 2 John W. Linville 2011-02-07 15:55:34 UTC
What driver are you using?
Comment 3 Cijoml Cijomlovic Cijomlov 2011-02-07 20:58:43 UTC
2.6.37, I tested both drivers staging RT2860STA and rt2x00. Both behaves the same way.
Last working kernel for me was 2.6.32.X with RT2860STA driver (rt2x00 was included later to vanilla kernel)
Comment 4 Alan 2013-12-11 12:17:38 UTC

Closing as obsolete, if this is still seen on modern kernels please update
Comment 5 Cijoml Cijomlovic Cijomlov 2013-12-11 12:33:48 UTC
This is still valid even for newest 3.12 kernel :(
Comment 6 Alan 2013-12-11 13:01:03 UTC
Thanks
Comment 7 Stanislaw Gruszka 2013-12-11 13:49:01 UTC
This will not be fixed, it is up to user space to establish connection correctly after resume from suspend. It worked before, because of using staging driver.

NetworkManager react properly on suspend/resume, if you want to use wpa_supplicant you should add hook to /etc/pm/sleep.d/ which which will stop/start supplicant on suspend/resume.

Note You need to log in before you can comment on or make changes to this bug.