Bug 28102 - New display errors in 2.6.38-rc2-00175-g6fb1b30
Summary: New display errors in 2.6.38-rc2-00175-g6fb1b30
Status: CLOSED UNREPRODUCIBLE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-dri-intel@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks: 27352
  Show dependency tree
 
Reported: 2011-02-02 20:27 UTC by Maciej Rutecki
Modified: 2011-06-18 19:27 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.38-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-02-02 20:27:16 UTC
Subject    : New display errors in 2.6.38-rc2-00175-g6fb1b30
Submitter  : Nico Schottelius <nico-kernel-20110117@schottelius.org>
Date       : 2011-01-28 20:29
Message-ID : 20110128202905.GB3395@schottelius.org
References : http://marc.info/?l=linux-kernel&m=129624657425949&w=2

This entry is being used for tracking a regression from 2.6.37. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Nico Schottelius 2011-02-24 17:48:08 UTC
Still happens in vmlinuz-2.6.38-rc6-00020-gd8204a3.

I tried to bisect, but most versions in between of 2.6.38-rc2-00175-g6fb1b30
and 2.6.37 crash, so I stopped trying.
Comment 2 Rafael J. Wysocki 2011-04-05 06:20:30 UTC
On Monday, April 04, 2011, Nico Schottelius wrote:
> Hey!
> 
> I've tested 2.6.38, which does not have this bug anymore.
Comment 3 Manfred Kitzbichler 2011-06-18 19:27:41 UTC
Please reopen this bug, it seems to be a regression even into 2.6.39 !

This is my kernel version:
2.6.39.1-32-default #1 SMP Sun Jun 12 23:19:51 UTC 2011 (fb46697) x86_64 x86_64 x86_64 GNU/Linux

And this is what I found in my "warn" log file after my display crashed showing scary static:
[drm:ironlake_fdi_link_train] *ERROR* FDI train 2 fail!

My CPU is an Intel core i5 M560 with integrated graphics, so it's using the i915 kernel module.

Xorg.0.log contains this:
[    25.651] (II) intel(0): Integrated Graphics Chipset: Intel(R) Arrandale
[    25.651] (--) intel(0): Chipset: "Arrandale"


I had similar problems with kernel 2.6.38 when I tried it on my openSUSE, so I went back to 2.6.37 where everything seems to work fine. Now that 2.6.39 came out, I hoped these issues were resolved, but this does not seem to be the case.

Based on Chris Wilson's comment on the original bug report it would appear that the unstable power saving features of the Ironlake CPU which had been taken out of the kernel were put back in - again. This seems to have produced regressions already at least twice.

Note You need to log in before you can comment on or make changes to this bug.