Bug 28072 - 2.6.38rc Kernels break LCD brightness adjustment on Acer Laptop
2.6.38rc Kernels break LCD brightness adjustment on Acer Laptop
Status: CLOSED DUPLICATE of bug 27702
Product: ACPI
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: acpi_other
:
Depends on:
Blocks: 27352
  Show dependency treegraph
 
Reported: 2011-02-01 23:07 UTC by Andy
Modified: 2011-02-02 20:15 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.38rc3
Tree: Mainline
Regression: Yes


Attachments
dmesg dump (56.09 KB, text/x-log)
2011-02-01 23:09 UTC, Andy
Details

Description Andy 2011-02-01 23:07:26 UTC
Description of problem:

Kernel Linux garage 2.6.38-rc3 #1 SMP Tue Feb 1 17:12:58 EST 2011 x86_64 x86_64 x86_64 GNU/Linux LCD brightness function keys on Acer laptop.  This works fine in 2.6.37 builds.  So far all .38 builds have had this problem.


00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07) (prog-if 00 [VGA controller])
	Subsystem: Acer Incorporated [ALI] Device 029b
	Flags: bus master, fast devsel, latency 0, IRQ 43
	Memory at d0000000 (64-bit, non-prefetchable) [size=4M]
	Memory at c0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at 30d0 [size=8]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
	Capabilities: [d0] Power Management version 3
	Kernel driver in use: i915
	Kernel modules: i915

00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
	Subsystem: Acer Incorporated [ALI] Device 029b
	Flags: bus master, fast devsel, latency 0
	Memory at d2400000 (64-bit, non-prefetchable) [size=1M]
	Capabilities: [d0] Power Management version 3


Please see attached dmesg output.  Happy to provide any other info or test
builds/patches etc.
Comment 1 Andy 2011-02-01 23:09:05 UTC
Created attachment 45922 [details]
dmesg dump
Comment 2 Andy 2011-02-01 23:15:30 UTC
Downstream tracker:

https://bugzilla.redhat.com/show_bug.cgi?id=672716

It was filed before I tested the vanilla kernel above.

Thanks!
Comment 3 Rafael J. Wysocki 2011-02-01 23:51:30 UTC
Please test the patch in bug #27702.
Comment 4 Andy 2011-02-02 01:28:40 UTC
Confirmed, the patch in 27702 fixes the issue.

Thanks.
Comment 5 Rafael J. Wysocki 2011-02-02 20:00:39 UTC

*** This bug has been marked as a duplicate of bug 27702 ***

Note You need to log in before you can comment on or make changes to this bug.