Bug 27922 - setting graphics mode for text console with video= instead of vga= does not work
Summary: setting graphics mode for text console with video= instead of vga= does not work
Status: RESOLVED INVALID
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-31 22:35 UTC by Elmar Stellnberger
Modified: 2012-03-05 16:56 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.38-0.0.7
Tree: Mainline
Regression: No


Attachments

Description Elmar Stellnberger 2011-01-31 22:35:16 UTC
I have stated "video=1920x1200-24@60" on my kernel command line. Instead it initializes a 80x25 text console with a low resolution of sth. like 640x480 or so.

  The video kernel command line is said to be the future replacement of vga= modes by the Xorg development team (vga= is said to be no more compatible with Xorg`s video mode initialization). 

Is it already implemented?
If yes a fallback to a similar Vesa graphics mode with Vesa safe/restore mode on vt-switch may be an additional opportunity.

occurs with and without kernel modesetting.
Comment 1 Felix Miata 2011-03-08 00:16:11 UTC
With radeon rv380 and a P275 Trinitron CRT, video=1024x768 on cmdline instead of vga=0xwhatever or vga=7whatever works for me with default modesetting state and Kulow/openSUSE kernel-desktop-2.6.37.2-3 and GA kernel-default-2.6.37.1-1.2 to produce same result on tty[1-6] as vga=791/vga=0x305/vga=0x317/vga=0x318 did before KMS implementation.
Comment 2 Elmar Stellnberger 2012-03-03 16:10:57 UTC
  As far as I have tested it on my machine the radeon module needs to be loaded with KMS enabled (no radeon.modeset=0 parameter) to get the video kernel-cmdline option interpreted (/proc/cmdline). If you f.i. need to use uvesafb instead give the following option: uvesafb.mode_option=1600x1200-24@60 (1920x1200 is no Vesa mode). The same parameters can be given on modeprobe leaving the module name (radeon., uvesafb.) out (/usr/src/linux-ver/Documentation/fb).
Comment 3 Jérôme Glisse 2012-03-05 16:56:01 UTC
This is not a bug, video= command line is only interpreted with kernel modesetting enabled. We don't support anymore non kernel modesetting case for radeon.

Note You need to log in before you can comment on or make changes to this bug.