Bug 27842 - [regression?] hang with 2.6.37 on a BTRFS test machine
[regression?] hang with 2.6.37 on a BTRFS test machine
Status: CLOSED UNREPRODUCIBLE
Product: File System
Classification: Unclassified
Component: btrfs
All Linux
: P1 normal
Assigned To: fs_btrfs@kernel-bugs.osdl.org
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2011-01-29 20:52 UTC by Maciej Rutecki
Modified: 2011-03-29 20:41 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.37
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-01-29 20:52:56 UTC
Subject    : [regression?] hang with 2.6.37 on a BTRFS test machine
Submitter  : Martin Steigerwald <Martin@lichtvoll.de>
Date       : 2011-01-23 12:06
Message-ID : 201101231306.23069.Martin@lichtvoll.de
References : http://marc.info/?l=linux-kernel&m=129578445613283&w=2

This entry is being used for tracking a regression from 2.6.36. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Martin Steigerwald 2011-02-03 11:21:59 UTC
Added linux-btrfs and Helmut Hullen, who seemed to experience hangs on a T23 with BTRFS as well, to Cc.

Am Thursday 03 February 2011 schrieb Rafael J. Wysocki:
> This message has been generated automatically as a part of a report
> of regressions introduced between 2.6.36 and 2.6.37.
> 
> The following bug entry is on the current list of known regressions
> introduced between 2.6.36 and 2.6.37.  Please verify if it still should
> be listed and let the tracking team know (either way).
> 
> 
> Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=27842
> Subject		: [regression?] hang with 2.6.37 on a BTRFS test machine
> Submitter	: Martin Steigerwald <Martin@lichtvoll.de>
> Date		: 2011-01-23 12:06 (11 days old)
> Message-ID	: <201101231306.23069.Martin@lichtvoll.de>
> References	: http://marc.info/?l=linux-kernel&m=129578445613283&w=2

Well I now tested with 2.6.36 for more than a week and I did not see any of such hangs upto now. The machine seems table with 2.6.36. So I think its really an regression of 2.6.37.

I am stuck with what to try next. Since trying to track it down to a specific commit appears too involved for me and its appears also quite laborious to get any value debug information out of the kernel - cause it can take days for the bug to appear -, I am inclined to either test with 2.6.37.1 once its available or just give it a go with 2.6.38-rc3 or rc4. Maybe 2.6.38-rc3/4 would be the best bet, I have seen a report on the btrfs mailing list of 2.6.38 fixing a BTRFS hang bug that appeared with 2.6.37. I am just not sure whether its related or not.

Re: [PATCH v2]Btrfs: pwrite blocked when writing from the mmaped buffer of the same page
http://marc.info/?l=linux-btrfs&m=129623925116051&w=2

There is another thread about 2.6.37 related BTRFS hang:

flush-btrfs-1 hangs when building openwrt
http://marc.info/?l=linux-btrfs&m=129594547616298&w=2

I will add this as comment to the bug report as well.

Thanks,
Martin
Comment 2 Martin Steigerwald 2011-02-03 11:45:25 UTC
Could bug#27132 be related?
Comment 3 Florian Mickler 2011-03-05 01:44:30 UTC
Could #29952 be related to this bug?
Comment 4 Martin Steigerwald 2011-03-29 08:59:12 UTC
Dunno. But I didn't see this bug with 2.6.38 and 2.6.38.1 so far. Please close - I do not have the access rights to do it. Raphael recommends closing as "irreproducible" in that case, cause its not really clear that it has been fixed when its irreproducible in a newer version.

THanks.
Comment 5 Florian Mickler 2011-03-29 20:41:14 UTC
Closed. Thx.

Note You need to log in before you can comment on or make changes to this bug.