Bug 27832 - wakeup broken
wakeup broken
Status: CLOSED UNREPRODUCIBLE
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks: 7216 21782
  Show dependency treegraph
 
Reported: 2011-01-29 20:37 UTC by Thomas Creutz
Modified: 2011-02-02 23:05 UTC (History)
3 users (show)

See Also:
Kernel Version: >=2.6.37-rc4
Tree: Mainline
Regression: Yes


Attachments
hwinfo output (482.89 KB, text/plain)
2011-01-29 20:39 UTC, Thomas Creutz
Details
acpidump output (192.24 KB, text/plain)
2011-01-29 20:47 UTC, Thomas Creutz
Details
dmesg from 2.6.37-rc4 (80.68 KB, text/plain)
2011-01-29 21:51 UTC, Thomas Creutz
Details
dmesg from 2.6.38-rc2 (77.23 KB, text/plain)
2011-01-29 22:07 UTC, Thomas Creutz
Details
new acpidump output with bios version a10 (192.24 KB, text/plain)
2011-01-29 22:26 UTC, Thomas Creutz
Details
new dmesg from 2.6.38-rc2 with bios version a10 (76.34 KB, text/plain)
2011-01-29 22:27 UTC, Thomas Creutz
Details

Description Thomas Creutz 2011-01-29 20:37:48 UTC
Hi,

since kernel >= 2.6.37-rc4 I cannot wake up my system from S3 standby.

my system is Ubuntu 10.04 with follow kernels from kernel-ppa.

2.6.32-28-generic-pae (2.6.32.27+drm33.12)
2.6.36-1-generic-pae (2.6.36)
2.6.37-8-generic-pae (2.6.37-rc4)
2.6.37-9-generic-pae (2.6.37-rc5)
2.6.37-12-generic-pae (2.6.37)

My System is: Dell Vostro 3700
For more details see attachment

So.. short explanation: after power on my laptop from standby it just stay black. when I press _short_ the powerbutton the system is powered off.

I also compared the kernel config from 2.6.37-8-generic-pae to 2.6.37-9-generic-pae - but there is no specified change to any acpi/power related stuff only some additional video- and dvb-drivers.

King Regards,
Thomas
Comment 1 Thomas Creutz 2011-01-29 20:39:19 UTC
Created attachment 45472 [details]
hwinfo output
Comment 2 Thomas Creutz 2011-01-29 20:47:24 UTC
Created attachment 45482 [details]
acpidump output
Comment 3 Rafael J. Wysocki 2011-01-29 20:59:27 UTC
Can you verify that the problem is still present in the current Linus'
tree (2.6.38-rc2 at least)?

We've had several fixes in this area since 2.6.37.
Comment 4 Thomas Creutz 2011-01-29 21:51:35 UTC
Created attachment 45492 [details]
dmesg from 2.6.37-rc4

yes, I will do it with the next reboot, mainline-kernel now installed from kernel-ppa

But also I want to add dmesg from working 2.6.37-rc4 with working resume/wakeup output.
Comment 5 Thomas Creutz 2011-01-29 22:07:30 UTC
Created attachment 45512 [details]
dmesg from 2.6.38-rc2

yes, resume works, but not very well.. X needs really long to resume.. I attached the current dmesg
Comment 6 Thomas Creutz 2011-01-29 22:26:39 UTC
Created attachment 45522 [details]
new acpidump output with bios version a10

I found a new BIOS version and did a update, but wakeup got not changed.
Comment 7 Thomas Creutz 2011-01-29 22:27:35 UTC
Created attachment 45532 [details]
new dmesg from 2.6.38-rc2 with bios version a10
Comment 8 Thomas Creutz 2011-01-29 22:43:33 UTC
I found this in dmesg (with both bios versions)

[  176.779031] ------------[ cut here ]------------
[  176.779037] WARNING: at /home/kernel-ppa/COD/linux/kernel/power/suspend_test.c:53 suspend_test_finish+0x8c/0x90()
[  176.779039] Hardware name: Vostro 3700
[  176.779040] Component: resume devices, time: 61092
[  176.779041] Modules linked in: binfmt_misc rfcomm l2cap bluetooth ppdev sit parport_pc xfrm_user xfrm4_tunnel tunnel4 ipcomp xfrm_ipcomp esp4 ah4 deflate zlib_deflate ctr twofish_generic twofish_i586 twofish_common camellia serpent blowfish cast5 des_generic aesni_intel cryptd aes_i586 aes_generic xcbc rmd160 sha512_generic sha256_generic sha1_generic crypto_null af_key dm_crypt snd_hda_codec_hdmi nvidia(P) snd_hda_codec_idt snd_hda_intel joydev snd_hda_codec snd_hwdep snd_pcm snd_seq_midi snd_rawmidi arc4 snd_seq_midi_event snd_seq snd_timer snd_seq_device iwlagn iwlcore mac80211 snd uvcvideo soundcore videodev dell_laptop sdhci_pci sdhci cfg80211 snd_page_alloc psmouse dell_wmi serio_raw intel_ips dcdbas sparse_keymap lp parport usbhid hid ahci libahci r8169
[  176.779078] Pid: 2651, comm: pm-suspend Tainted: P            2.6.38-020638rc2-generic #201101220905
[  176.779080] Call Trace:
[  176.779083]  [<c0189dcc>] ? suspend_test_finish+0x8c/0x90
[  176.779088]  [<c014fa21>] ? warn_slowpath_common+0x81/0xa0
[  176.779090]  [<c0189dcc>] ? suspend_test_finish+0x8c/0x90
[  176.779092]  [<c014fae3>] ? warn_slowpath_fmt+0x33/0x40
[  176.779094]  [<c0189dcc>] ? suspend_test_finish+0x8c/0x90
[  176.779096]  [<c0189b88>] ? suspend_devices_and_enter+0x98/0x130
[  176.779098]  [<c0189cec>] ? enter_state+0xcc/0xd0
[  176.779099]  [<c01891f2>] ? state_store+0x92/0xd0
[  176.779101]  [<c0189160>] ? state_store+0x0/0xd0
[  176.779104]  [<c0367f74>] ? kobj_attr_store+0x24/0x30
[  176.779109]  [<c027ea60>] ? flush_write_buffer+0x50/0x70
[  176.779111]  [<c027edc7>] ? sysfs_write_file+0x47/0x80
[  176.779115]  [<c022364b>] ? vfs_write+0x9b/0x160
[  176.779117]  [<c027ed80>] ? sysfs_write_file+0x0/0x80
[  176.779119]  [<c0223c82>] ? sys_write+0x42/0x70
[  176.779122]  [<c0102e1f>] ? sysenter_do_call+0x12/0x28
[  176.779124] ---[ end trace 0dbc020ba1e97f2b ]---
Comment 9 Rafael J. Wysocki 2011-01-29 23:53:02 UTC
From the attached dmesg it looks like you don't use a KMS graphics driver.

What graphics adapter is there in your machine?
Comment 10 Thomas Creutz 2011-01-30 18:31:47 UTC
sudo lspci -vs 01:00.0
01:00.0 VGA compatible controller: nVidia Corporation GT216 [GeForce GT 330M] (rev a2)
	Subsystem: Dell Device 0442
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at fa000000 (32-bit, non-prefetchable) [size=16M]
	Memory at c0000000 (64-bit, prefetchable) [size=256M]
	Memory at d0000000 (64-bit, prefetchable) [size=32M]
	I/O ports at e000 [size=128]
	[virtual] Expansion ROM at fb000000 [disabled] [size=512K]
	Capabilities: [60] Power Management version 3
	Capabilities: [68] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
	Capabilities: [78] Express Endpoint, MSI 00
	Capabilities: [b4] Vendor Specific Information <?>
	Capabilities: [100] Virtual Channel <?>
	Capabilities: [128] Power Budgeting <?>
	Capabilities: [600] Vendor Specific Information <?>
	Kernel driver in use: nvidia
	Kernel modules: nvidia-current, nouveau, nvidiafb
Comment 11 Rafael J. Wysocki 2011-01-30 22:28:06 UTC
Well, I think the resume problem is related to the nvidia driver being used,
in which case I can't help you, because this driver is not supported by the
kernel developers.

You may get better results, as far as suspend-resume is concerned, if you use
the nouveau driver (still, I'm not the right person to ask for help with this
driver, because I don't use any machines with NVidia graphics).
Comment 12 Thomas Creutz 2011-01-31 20:42:00 UTC
ok.. I was expecting such a answer ;-)

but I prefer to use nvidia driver, because I need vdpau interface for hd video acceleration and good 3d support.

But I can blacklist the driver for a test... but I don't think that I need it..

in the last time/tries the wakeup works really good.. don't now what was wrong before.
Comment 13 Rafael J. Wysocki 2011-01-31 20:45:14 UTC
That's fine if it works for you.  There might be some transient error that
has been fixed in the meantime.

I'll close the bug as "unreproducible", please reopen (or file a new one) if
the problem continues.

Note You need to log in before you can comment on or make changes to this bug.