Bug 27812 - 2.6.38-rc2: acpi backlight control missing
2.6.38-rc2: acpi backlight control missing
Status: CLOSED DUPLICATE of bug 27702
Product: ACPI
Classification: Unclassified
Component: Power-Video
All Linux
: P1 normal
Assigned To: acpi_power-video
:
Depends on:
Blocks: 27352
  Show dependency treegraph
 
Reported: 2011-01-29 13:57 UTC by Maciej Rutecki
Modified: 2011-02-09 23:04 UTC (History)
7 users (show)

See Also:
Kernel Version: 2.6.38-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-01-29 13:57:11 UTC
Subject    : 2.6.38-rc2: acpi backlight control missing
Submitter  : Thomas Meyer <thomas@m3y3r.de>
Date       : 2011-01-22 10:49
Message-ID : 1295693349.2120.3.camel@localhost.localdomain
References : http://marc.info/?l=linux-kernel&m=129569353414755&w=2

This entry is being used for tracking a regression from 2.6.37. Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 677bd810eedce61edf15452491781ff046b92edc
Author: Zhang Rui <rui.zhang@intel.com>
Date:   Mon Dec 6 15:04:21 2010 +0800

    ACPI video: remove output switching control

First-Bad-Commit : 677bd810eedce61edf15452491781ff046b92edc
Comment 1 Paulo Dias 2011-02-01 19:30:25 UTC
I can confirm this, modpring video and output.ko doesnt activate the /proc/acpi/etc... brightness device.

this is with a hp pavilion dv7 and kernel Linux hydra 2.6.38-020638rc3-generic #201102010912 SMP Tue Feb 1 09:14:19 UTC 2011 x86_64 GNU/Linux
Comment 2 Rafael J. Wysocki 2011-02-01 23:52:32 UTC
Please test the patch in bug #27702.
Comment 3 Zhang Rui 2011-02-09 02:35:29 UTC
ping
Comment 4 Paulo Dias 2011-02-09 16:31:32 UTC
i patched kernel 2.6.38 rc4 stock with the aforementioned patch, backlight works now as expected, great job :)
Comment 5 Florian Mickler 2011-02-09 23:03:32 UTC
Thank you for reporting your issue.

*** This bug has been marked as a duplicate of bug 27702 ***
Comment 6 Florian Mickler 2011-02-09 23:04:04 UTC
Or more exactly testing the patch.

Note You need to log in before you can comment on or make changes to this bug.