Bug 27702 - regression 2.6.37 -> 2.6.38-rc1: after suspend backlight cannot be adjusted
regression 2.6.37 -> 2.6.38-rc1: after suspend backlight cannot be adjusted
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Power-Video
All Linux
: P1 normal
Assigned To: acpi_power-video
:
: 26832 27812 28072 28942 (view as bug list)
Depends on:
Blocks: 7216 27352
  Show dependency treegraph
 
Reported: 2011-01-27 19:57 UTC by Maciej Rutecki
Modified: 2011-04-26 02:24 UTC (History)
9 users (show)

See Also:
Kernel Version: 2.6.38-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-01-27 19:57:00 UTC
Subject    : regression 2.6.37 -> 2.6.38-rc1: after suspend backlight cannot be adjusted
Submitter  : Norbert Preining <preining@logic.at>
Date       : 2011-01-21 1:55
Message-ID : 20110121015529.GD9796@gamma.logic.tuwien.ac.at
References : http://marc.info/?l=linux-kernel&m=129557717826819&w=2

This entry is being used for tracking a regression from 2.6.37. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Norbert Preining 2011-01-28 01:07:38 UTC
This patch solved the problem for me
https://patchwork.kernel.org/patch/499221/
Comment 2 Rafael J. Wysocki 2011-01-28 10:45:59 UTC
Patch : https://patchwork.kernel.org/patch/499221/
Handled-By : Michael Karcher <kernel@mkarcher.dialup.fu-berlin.de>
Comment 3 Rafael J. Wysocki 2011-02-02 20:00:39 UTC
*** Bug 28072 has been marked as a duplicate of this bug. ***
Comment 4 Paulo Dias 2011-02-08 14:47:31 UTC
Is this patch applied upstream already? i still dont have entries in /sys/class/backlight in 2.6.38 rc4 :(
Comment 5 Paulo Dias 2011-02-09 16:32:12 UTC
i patched kernel 2.6.38 rc4 stock with the aforementioned patch, backlight
works now as expected, great job :)
Comment 6 Florian Mickler 2011-02-09 23:03:32 UTC
*** Bug 27812 has been marked as a duplicate of this bug. ***
Comment 7 Zhang Rui 2011-02-10 01:45:00 UTC
*** Bug 26832 has been marked as a duplicate of this bug. ***
Comment 8 Norbert Preining 2011-02-15 13:32:02 UTC
I confirm that this regression is still present in git master as of commit 795abaf1e4e188c, latest checkout 2011-02-15 22:30 JST
Comment 9 Florian Mickler 2011-02-20 00:07:54 UTC
merged in (soon to be) .38-rc6: 
commit ed764e7ca042dbf4cc1c7f4e12cd842c7789f133
Author: Michael Karcher <kernel@mkarcher.dialup.fu-berlin.de>
Date:   Sat Feb 12 01:40:16 2011 +0100

    ACPI / Video: Probe for output switch method when searching video devices.
Comment 10 Len Brown 2011-04-26 02:24:32 UTC
*** Bug 28942 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.