Bug 27672 - [BUG] 2.6.38-rc1-git1: hard lockup related to i915 / automated cgroup scheduling
[BUG] 2.6.38-rc1-git1: hard lockup related to i915 / automated cgroup scheduling
Status: CLOSED DUPLICATE of bug 27862
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 27352
  Show dependency treegraph
 
Reported: 2011-01-26 21:03 UTC by Maciej Rutecki
Modified: 2011-02-01 10:44 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.38-rc1-git1
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-01-26 21:03:33 UTC
Subject    : [BUG] 2.6.38-rc1-git1: hard lockup related to i915 / automated cgroup scheduling
Submitter  : Knut Petersen <Knut_Petersen@t-online.de>
Date       : 2011-01-20 17:29
Message-ID : 4D387109.9020207@t-online.de
References : http://marc.info/?l=linux-kernel&m=129554559122704&w=2

This entry is being used for tracking a regression from 2.6.37. Please don't
close it until the problem is fixed in the mainline.
Comment 3 Chris Wilson 2011-01-29 14:26:52 UTC
Ah, I thought there was another issue with X left unresolved.
Comment 4 Florian Mickler 2011-01-29 16:55:17 UTC
Indeed. The original report was about a hard freeze and the issue solved by the above Patch was only _thought_ to be related.
Comment 6 Chris Wilson 2011-02-01 10:22:17 UTC
I think this is related to bug 27862 and the same 3 patches (drm-intel-fixes 9334ef755f060e251f3f395caeda1a58b6834ea3 and ddx 3e28a0c0b43823d3104fe8fc50b5994b41fc0cc1 c6dc27562abbc8ca9e873ad502ca49ae010461d2).

In particular,

commit 9334ef755f060e251f3f395caeda1a58b6834ea3
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Fri Jan 28 11:53:03 2011 +0000

    drm: Don't switch fb when disabling an output

    In drm_crtc_helper_set_config, we call drm_crtc_helper_set_mode which
    may return early and do no operation if the crtc is to be disabled. In
    this case we merrily swap to the new fb, discarding the old_fb believing
    that it has been cleaned up. However, due to the early return, the
    old_fb was not presented to the backend for correct reaping, and nor was
    the new one - which is about to be reaped via the
    drm_helper_disable_unused_functions(), leading to incorrect refcounting
    of the pinned objects.

    Bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=27722
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=29857
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=29230
    Tested-by: Takashi Iwai <tiwai@suse.de>
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>

is magic.
Comment 7 Rafael J. Wysocki 2011-02-01 10:44:17 UTC

*** This bug has been marked as a duplicate of bug 27862 ***

Note You need to log in before you can comment on or make changes to this bug.