Bug 27642 - 2.6.37 says WARNING: at arch/x86/kernel/apic/apic.c:1287 setup_local_APIC+0x18f/0x263()
2.6.37 says WARNING: at arch/x86/kernel/apic/apic.c:1287 setup_local_APIC+0x1...
Status: RESOLVED OBSOLETE
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: platform_i386
:
Depends on:
Blocks: 21782
  Show dependency treegraph
 
Reported: 2011-01-26 20:20 UTC by Maciej Rutecki
Modified: 2013-12-11 12:06 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.37
Tree: Mainline
Regression: Yes


Attachments
VirtualBox vminfo output for Fedora 14 Virtual Machine (2.22 KB, text/plain)
2011-05-02 04:43 UTC, Scott Marshall
Details
XML format Virtual Machine description/configuration (15.46 KB, application/xml)
2011-05-02 04:50 UTC, Scott Marshall
Details
The native VirtualBox "vbox" configuration file (9.82 KB, application/x-virtualbox-vbox)
2011-05-02 04:55 UTC, Scott Marshall
Details

Description Maciej Rutecki 2011-01-26 20:20:34 UTC
Subject    : 2.6.37 says WARNING: at arch/x86/kernel/apic/apic.c:1287 setup_local_APIC+0x18f/0x263()
Submitter  : Rob Landley <rlandley@parallels.com>
Date       : 2011-01-18 13:11
Message-ID : 4D359188.3040408@parallels.com
References : http://marc.info/?l=linux-kernel&m=129535632319892&w=2

This entry is being used for tracking a regression from 2.6.37. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Florian Mickler 2011-03-29 21:07:15 UTC
Is this still happening on 2.6.38.y? Is there any misbehaviour accompanying the warning?
Comment 2 Rob Landley 2011-03-30 01:44:44 UTC
I haven't seen it in 2.6.38, I think it's been fixed.
Comment 3 Florian Mickler 2011-03-30 20:04:04 UTC
Alright, thanks for the update. I'm closing this as unreproducible.
Comment 4 Scott Marshall 2011-05-01 10:11:17 UTC
Guys, sorry to burst your bubble, but I have the same (or very similar) ABRT oops report for kernel release 2.6.38 when compiled on/under Fedora 14.

https://bugzilla.redhat.com/show_bug.cgi?id=701115

kernel: WARNING: at arch/x86/kernel/apic/apic.c:1284 setup_local_APIC+0x15b/0x20b()

The source line in apic.c and the function offset are different, but only by 3 lines in the source code.

The specific kernel source was downloaded from the Fedora 15 SRPM directory, and compiled on/under a working Fedora 14 x86_64 system.

I only seem to get these APIC errors when running in virtual machines, such as those provided by Oracle VirtualBox.

The VirtualBox under which this occurred for me is v4.0.6 running in a Windows 7 x86_64 host, fully patched.

I hope this helps narrow down the root cause of the abend.
Comment 5 Scott Marshall 2011-05-01 13:20:42 UTC
Backtrace from abrt:

WARNING: at arch/x86/kernel/apic/apic.c:1284 setup_local_APIC+0x15b/0x20b()
Hardware name: VirtualBox
Modules linked in:
Pid: 1, comm: swapper Not tainted 2.6.38.3-18.fc14.x86_64 #1
Call Trace:
 [<ffffffff81058f5f>] ? warn_slowpath_common+0x85/0x9d
 [<ffffffff81058f91>] ? warn_slowpath_null+0x1a/0x1c
 [<ffffffff81482318>] ? setup_local_APIC+0x15b/0x20b
 [<ffffffff812443d9>] ? __bitmap_weight+0x3e/0x8a
 [<ffffffff81b6591e>] ? native_smp_prepare_cpus+0x29b/0x34b
 [<ffffffff81b58ce1>] ? kernel_init+0x92/0x2b6
 [<ffffffff8100ba64>] ? kernel_thread_helper+0x4/0x10
 [<ffffffff81b58c4f>] ? kernel_init+0x0/0x2b6
 [<ffffffff8100ba60>] ? kernel_thread_helper+0x0/0x10
Comment 6 Scott Marshall 2011-05-02 04:43:31 UTC
Created attachment 56142 [details]
VirtualBox vminfo output for Fedora 14 Virtual Machine

Output file generated by:

vboxmanage showvminfo "Fedora 14 x64" --machinereadable

This may assist in reproducing or narrowing down cause of the APIC errors.
Comment 7 Scott Marshall 2011-05-02 04:50:17 UTC
Created attachment 56152 [details]
XML format Virtual Machine description/configuration

Output from the:

vboxmanage export "Fedora 14 x64" --output Fed14x64.ovf

Once again, the analysis of the XML configuration may assist in determining what VirtualBox is doing when creating the virtual machine environment, and how it affects the kernel APIC code.

(And no, I'm not going to upload the companion vmdk file - it's too bl**dy big - the raw file is ~36GiB in size)
Comment 8 Scott Marshall 2011-05-02 04:55:45 UTC
Created attachment 56162 [details]
The native VirtualBox "vbox" configuration file

Once again, the configuration of the Oracle VirtualBox virtual machine environment where the kernel is experiencing APIC errors.

This is the NATIVE Oracle virtualBox configuration format.
Comment 9 Alan 2013-12-11 12:06:20 UTC

Closing as obsolete, if this is still seen on modern kernels please update

Note You need to log in before you can comment on or make changes to this bug.