Bug 27632 - 2.6.37-git16 -- INFO: HARDIRQ-safe -> HARDIRQ-unsafe lock order detected
2.6.37-git16 -- INFO: HARDIRQ-safe -> HARDIRQ-unsafe lock order detected
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 normal
Assigned To: drivers_network-wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks: 27352
  Show dependency treegraph
 
Reported: 2011-01-26 20:17 UTC by Maciej Rutecki
Modified: 2011-01-29 11:59 UTC (History)
7 users (show)

See Also:
Kernel Version: 2.6.37-git16
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2011-01-26 20:17:09 UTC
Subject    : 2.6.37-git16 -- INFO: HARDIRQ-safe -> HARDIRQ-unsafe lock order detected
Submitter  : Miles Lane <miles.lane@gmail.com>
Date       : 2011-01-17 21:29
Message-ID : AANLkTik2r1P9dqyw+QoHg9G3PUvvPukY08TpS5Ud1ffG@mail.gmail.com
References : http://marc.info/?l=linux-kernel&m=129529978925170&w=2

This entry is being used for tracking a regression from 2.6.37. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Johannes Berg 2011-01-26 21:54:46 UTC
Err, this has been fixed a long time ago in the lockdep fix in mac80211.
Comment 2 Florian Mickler 2011-01-29 11:59:10 UTC
do you mean (merged in v2.6.38-rc2)?: 
commit 681c4d07dd5b2ce2ad9f6dbbf7841e479fbc7754
Author: Johannes Berg <johannes.berg@intel.com>
Date:   Wed Jan 12 13:40:33 2011 +0100

    mac80211: fix lockdep warning


I'm wondering why there is no answer to the message referenced above? How was this handled? Miles is credited as reported-by:...

Note You need to log in before you can comment on or make changes to this bug.