Bug 27422 - NFS OOps - kernel BUG at fs/nfs/nfs3xdr.c:1338
NFS OOps - kernel BUG at fs/nfs/nfs3xdr.c:1338
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: NFS
All Linux
: P1 normal
Assigned To: Trond Myklebust
:
Depends on:
Blocks: 27352
  Show dependency treegraph
 
Reported: 2011-01-23 17:39 UTC by Maciej Rutecki
Modified: 2011-01-31 17:38 UTC (History)
3 users (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: Yes


Attachments
NFS: Fix "kernel BUG at fs/nfs/nfs3xdr.c:1338!" (4.60 KB, patch)
2011-01-28 22:27 UTC, Trond Myklebust
Details | Diff

Description Maciej Rutecki 2011-01-23 17:39:21 UTC
Subject    : NFS OOps  - kernel BUG at fs/nfs/nfs3xdr.c:1338
Submitter  : Milan Broz <mbroz@redhat.com>
Date       : 2011-01-14 23:18
Message-ID : 4D30D9D6.2080809@redhat.com
References : http://marc.info/?l=linux-kernel&m=129504714503972&w=2

This entry is being used for tracking a regression from 2.6.37. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Trond Myklebust 2011-01-28 22:27:26 UTC
Created attachment 45422 [details]
NFS: Fix "kernel BUG at fs/nfs/nfs3xdr.c:1338!"

nfs3_xdr_enc_setacl3args() is not properly setting up the target
buffer before nfsacl_encode() attempts to encode the ACL.

Introduced by commit d9c407b1 "NFS: Introduce new-style XDR encoding
functions for NFSv3."

Signed-off-by: Chuck Lever <chuck.lever@oracle.com>
Signed-off-by: Trond Myklebust <Trond.Myklebust@netapp.com>

Note You need to log in before you can comment on or make changes to this bug.