Bug 27412 - Asus N61JQ does not shutdown unless nolapic given
Summary: Asus N61JQ does not shutdown unless nolapic given
Status: CLOSED CODE_FIX
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Off (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: acpi_power-off
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-23 16:51 UTC by Ozan Caglayan
Modified: 2011-07-30 06:56 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.37
Tree: Mainline
Regression: No


Attachments
dmesg after booting normally (97.44 KB, text/plain)
2011-01-23 16:53 UTC, Ozan Caglayan
Details
dmesg after booting with nolapic (shutdowns correctly) (95.45 KB, text/plain)
2011-01-23 16:54 UTC, Ozan Caglayan
Details
Screenshot of hung shutdown (348.08 KB, image/jpeg)
2011-01-23 16:54 UTC, Ozan Caglayan
Details
Screenshot of successful shutdown with nolapic (66.78 KB, image/jpeg)
2011-01-23 16:55 UTC, Ozan Caglayan
Details

Description Ozan Caglayan 2011-01-23 16:51:31 UTC
Asus N61JQ does not shutdown unless nolapic given. I'm attaching relevant informations.
Comment 1 Ozan Caglayan 2011-01-23 16:53:31 UTC
Created attachment 44852 [details]
dmesg after booting normally
Comment 2 Ozan Caglayan 2011-01-23 16:54:09 UTC
Created attachment 44862 [details]
dmesg after booting with nolapic (shutdowns correctly)
Comment 3 Ozan Caglayan 2011-01-23 16:54:47 UTC
Created attachment 44872 [details]
Screenshot of hung shutdown
Comment 4 Ozan Caglayan 2011-01-23 16:55:21 UTC
Created attachment 44882 [details]
Screenshot of successful shutdown with nolapic
Comment 5 Ozan Caglayan 2011-01-23 17:35:29 UTC
This happens occasionally, not on every boot.
Comment 6 Rafael J. Wysocki 2011-01-23 20:39:52 UTC
This looks like a cpuidle bug to me.
Comment 7 Ozan Caglayan 2011-01-29 17:50:31 UTC
intel_idle enabled and the suggested patches are applied:

From 2a2d31c8dc6f1ebcf5eab1d93a0cb0fb4ed57c7c Mon Sep 17 00:00:00 2001
From: Shaohua Li <shaohua.li@intel.com>
Date: Mon, 10 Jan 2011 09:38:12 +0800
Subject: [PATCH 3/5] intel_idle: open broadcast clock event

From ec30f343d61391ab23705e50a525da1d55395780 Mon Sep 17 00:00:00 2001
From: Shaohua Li <shaohua.li@intel.com>
Date: Mon, 24 Jan 2011 08:00:01 +0000
Subject: [PATCH 5/5] fix a shutdown regression in intel_idle

Fix a shutdown regression caused by 2a2d31c8dc6f ("intel_idle: open
broadcast clock event").  The clockevent framework can automatically
shutdown broadcast timers for hotremove CPUs.  And we get a shutdown
regression when we shutdown broadcast timer for hot remove CPU, so just
delete some code.

The user reported that 1 out of 2 shutdown attempts failed.
Comment 8 Rion 2011-03-20 20:16:41 UTC
I experience the same with my Toshiba Satellite A300 1G2 but on every boot.

Linux dizzynb.local 2.6.37.4-zen+ #3 ZEN SMP PREEMPT Sun Mar 20 15:40:09 YEKT 2011 x86_64 Intel(R) Pentium(R) Dual CPU T2390 @ 1.86GHz GenuineIntel GNU/Linux.

patches above are included
Comment 9 Ozan Caglayan 2011-03-20 21:46:07 UTC
The user reported back that he's not having these random shutdown hangs with 2.6.37.2, I think that we can close this bug as fixed.

Regarding your issue with Toshiba Satellite, I think you should file a new bug report and try to determine the last good and the first bad kernel versions if possible in order to speed up the bug triaging process.

Thanks.

Closing this with CODE_FIX but we don't actually know which commit fixed this in 2.6.37.y stable branch.
Comment 10 Rion 2011-03-21 18:49:02 UTC
just compiled 2.6.38. no bugs =)

Note You need to log in before you can comment on or make changes to this bug.