Bug 27242 - Hard lock while booting Acer Aspire 1310 with kernel since 2.6.32 and acpi activated
Hard lock while booting Acer Aspire 1310 with kernel since 2.6.32 and acpi ac...
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: platform_i386
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2011-01-21 07:26 UTC by werbung2007
Modified: 2011-02-03 18:55 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.32 up to 2.6.37
Tree: Mainline
Regression: Yes


Attachments

Description werbung2007 2011-01-21 07:26:11 UTC
I'm using an Acer Aspire 1310 notebook for several years and never had a problem with ACPI. But since update to kernel 2.6.32 I cannot longer boot with acpi on. I've tested several acpi settings. Only with acpi=off (or acpi=ht with kernel < 2.6.37) is able to boot.

After several help on <https://bugzilla.novell.com/show_bug.cgi?id=623393> (many thanks to Rafael Wysocki) we found out, that the 35th call of acpi_init_one_device does not return from acpi_ns_evaluate. If I add some crude code to acpi_init_one_device to immediate return with return_ACPI_STATUS(AE_CTRL_DEPTH) from 35th call of acpi_ns_evaluate, kernel 2.6.37 boots!

You may find more information, e.g., several attachments like acpi dump, screen photo of the hard lock, outputs of dmesg, lspci, and dmidecode on <https://bugzilla.novell.com/show_bug.cgi?id=623393>.
Comment 1 werbung2007 2011-02-03 09:12:10 UTC
Suresh Siddha submitted a patch for that problem. See <http://marc.info/?l=linux-kernel&m=129669498508824&w=2>.

Note You need to log in before you can comment on or make changes to this bug.