Bug 2713 - Synaptics touch pad not recognized under 2.6.X Kernels on Sharp MM20
Summary: Synaptics touch pad not recognized under 2.6.X Kernels on Sharp MM20
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Input Devices (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Dmitry Torokhov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-05-14 17:11 UTC by David Cafaro
Modified: 2006-01-30 08:54 UTC (History)
0 users

See Also:
Kernel Version: 2.6.0 - 2.6.6
Tree: Mainline
Regression: ---


Attachments
Automatically disable MUX mode on SHARP MM20 (642 bytes, patch)
2005-12-20 11:49 UTC, Dmitry Torokhov
Details | Diff

Description David Cafaro 2004-05-14 17:11:48 UTC
Distribution: Fedora Core 1 + Fedora Core 2 Test 3

Hardware Environment: Sharp MM20 Laptop, Efficeon Processor, ATI Radeon,
Synaptics Touch pad

Software Environment: XFree86 4.3, With and Without Syanptics Linux driver 11.0
- 13.2

Problem Description:

The 2.6.0 Kernels do not recognize the Synaptics Touchpad on the Sharp MM20
laptop computer.  The Touchpad is recognized and fully functional under the
2.4.22 kernel (maybe others, haven't tested).  I have run the 2.6.6 kernel under
Fedora Core 1 and experienced the lack of touchpad (X starts but no mouse
movement, cat'ing devices recieves no data).  I recieve the same problem with
the 2.6.5 kernel that comes with Fedora Core 2 Test 3 (install won't start
because it can't find the mouse).  Have tried multiple kernel boot options
(pci=noacpi, psmouse.proto=imps, acpi=off, psmouse_noext=1) and with and without
the Synaptice Touchpad driver (Synaptics driver works perfectly under 2.4.22
kernel).  Kernel was compiled with psmouse and evdev as modules and as kernel. 

Steps to reproduce:

Boot with any 2.6.x series kernel on the Sharp MM20 laptop.

Steps to solve:

I have found that adding this kernel command "i8042.nomux" to the grub boot
loader, brings back the mouse and solves the problem.  Now in dmesg I can see
the kernel finding the Synaptics touchpad, where before dmesg showed no
Synaptics touchpad.
Comment 1 Dmitry Torokhov 2005-12-16 07:15:28 UTC
Could you tell me if there are external PS/2 ports on your laptop. If not, 
could you please send output of dmidecode utility to dtor_core@ameritech.net?
Comment 2 David Cafaro 2005-12-20 07:24:26 UTC
Wow, I had forgotten about this bug.. Though last I tried with the 2.6.13
kernels I was still having this issue.

I'll try and give you what I can, but currently I'm not running linux on this
laptop (due to numberous frustrating errors related to suspend and seperately DRI).

Anyways, there are no external PS/2 ports on the laptop.  As for getting
dmidecode results to you, I'll see if I can boot the system up with a live CD
edition to get that info.  Need to find a CD drive though (none built in), this
is one of those ultra portable laptops.
Comment 3 Dmitry Torokhov 2005-12-20 07:45:16 UTC
Thank you for your response. I searched on the net and found couple of pages 
referencing Linux installs on this laptop. Let's see if they still have Linux 
running and maybe I will get dmidecode data from them.
Comment 4 Dmitry Torokhov 2005-12-20 07:48:00 UTC
Dang, I just realised, one of these persons were you. OOps ;) Let's see if the 
other person responds... 
Comment 5 David Cafaro 2005-12-20 08:04:37 UTC
No problem, I'm trying a live CD, but so far no luck, will boot off the CD but
once they try to startup suddenly they can't see the USB drive anymore and
panic.  Go figure...
Comment 6 David Cafaro 2005-12-20 08:37:50 UTC
dmidecode run, and email sent, hope that helps.
Comment 7 Dmitry Torokhov 2005-12-20 11:49:25 UTC
Created attachment 6867 [details]
Automatically disable MUX mode on SHARP MM20

With this patch you should not need to pass i8042.nomux on the command line to
have your touchpad detected.
Comment 8 Dmitry Torokhov 2006-01-30 08:54:44 UTC
The patch is included in 2.6.16-rc1, closing the bug.

Note You need to log in before you can comment on or make changes to this bug.